Galaxy S4 Custom ROM's Issues (no sound, black screen on call)


Feb 6, 2013
Hello Folks,

Forgive me if i have posted the thread in the wrong section or of any other reason.

I have an issue since i start installing custom ROMS. So, straight to the point.

What have I done so far?

is not my first time installing a ROM. I have installed stock ROM's in the past. However, not custom ones. I have rooted my device in the past and even now before installing a custom ROM. I have installed through TWRP recovery various custom ROMS such as Omega, AOSP, ARROW, WanamLite, Google Edition and CyanogenMod but none of them worked fine for me.

What Issues I experience?

In some ROMS I might not have reception (don't worry the IMEI is the same and backed up). However, in EVERY ROM my dialler crashes; for example, when im trying to make a call it freezes and the screen goes black without seeing anything. On the other hand, when I receive a call, screen takes ages to appear and show the caller or even accept the call. In addition, I have NO SOUND at all in every ROM as well.

What I think the problem is?

I believe that the kernel might be the problem. This is because when i am booting the phone I always see the following:

kernel is not seandroid enforcing
set warranty bit: kernel

I have tried clearing cache, dalvik, removing battery, installing stock ROMS etc.... and nothing changed!

I would much appreciate if you could help me with my problem as my phone is not usable at all like this.

Many thanks,


Oct 30, 2013
Have you tried going back to FULL stock, e.g. unrooting, flashing stock rom (not a stock BASED ROM), no trace of rooting left. If you haven't try that and see if your problem still persists, if it does then it may be hardware problem. If it goes away then it's probably a kernel/ROM problem. If it still keeps on happening ask in the relevant forum on XDA. If they can't help you go back to stock and and un root and pretty much get rid of every trace of rooting. Then send it back for warranty or repair if possible

EDIT: Also you may want to try installing another kernel if possible. E.g. On the Nexus 7 2013 you can flash Franco kernel.


Feb 13, 2014
I have the exact issue with my i337m (Canada - Rogers) phone after flashing cyanogenmod 11 then back to stock via Odin. I don't have an answer, but did you experience it via the same method?