Game lags when laptop charger is plugged in

Feb 13, 2018
6
0
10
0
I am using Z580 i3,4gb,1tb,1gb..
I am facing this problem like when I play any game when charger is connected game start to lag...and when I disconnect it...it runs fine without lag...
1.I checked power setting its on high performance...advance setting is also on high...
2.Its not heating the laptop...

Thank you...
 

Robert Ban

Estimable
Jul 30, 2014
437
0
6,010
109
Here's fix


http://www.tomsguide.com/answers/id-1894048/laptop-lags-playing-games-plugged.html
 

GreyCatz

Admirable
We're going to need some more details about your system: Full computer name (brand and model) and CPU + GPU details. It would also be useful to know exactly which Windows version you're running as well as what kind of games you play.

It seems to be a power management issue, and it may be resolved by tweaking some CPU-related settings.

Go to Windows Control Panel->Hardware & sound->Power Options.

Click the 'Change plan settings' link.

Click the 'Change advanced power settings' link.

Scroll down and expand 'Processor power management'.

What are the values under 'Minimum processor state' and 'Maximum processor state'?
 
Feb 13, 2018
6
0
10
0


Brand: Lenovo
Series: Z Series
Model Number: Z 580 (59-347604)
Processor: Intel Core i3 3rd Gen.
GPU: NVIDIA GeForce GT 635M (1GB)
Win Verson: Windows 10

AND

Minimum processor state is 5% for both (Plug in and On battery)
Maximum processor state is 100% for both (Plug in and On battery)

AND
And currently I am playing "Middle-earth: Shadow of Mordor"..
It was running fine few day before...but now its lagging while plugged in..
 

GreyCatz

Admirable
Just a few more details:

- Go to Settings>System>About: Does it say U (= dual-core) or Q or K (= quad-core) in the CPU details?

- What is the Build version of your Windows 10 OS? (Scroll down a few lines).

Your minimum and maximum processor states are the default values. Try this:
Set Minimum Processor State to 50 for both.
Set Maximum Processor State to 99 for both.

The critical value is the Minimum Processor State. Try increasing the value to as much as 80. If you gain no improvement, you can reset the values.

I have to say I'm a bit surprised that you can play Shadows of Mordor with this CPU/GPU setup at all, and my guess is that the Lenovo is struggling to keep up regardless of the processor state values. Do you experience this kind of lag with other games as well or is it just Shadows of Mordor?

The reason it seems to play better on battery is probably that the system throttles down across the board while on battery - to save power - and when it's plugged in all the background services and features are running on their default settings. There are a number of tweaks you can do with Windows 10, including disabling notifications and pop-up messages. And keep in mind that Windows 10 will download and install updates automatically unless you set specific hours when it shouldn't ('Active hours').
 
Feb 13, 2018
6
0
10
0


In CPU details it says "Intel(r) core(tm) i3-3110m cpu @ 2.40ghz"
Build verson of OS is "Edition: Win10 Pro,Version: 1709,OS built: 16299.125".

AND

Yes, it happens with every game even low end games too,

AND

I tried changing those settings you mentioned but still no luck...

AND

I have already stopped auto update so when ever it needs to restart to update the system it ask me 1st
 

GreyCatz

Admirable
Thanks for the added details - but I can't find anything wrong with your system, except I suspect you're running a dual-core i3 and trying to play a very demanding game. But if it plays OK on battery, then I have no explanation.

Sorry,
GreyCatz.
 
Feb 13, 2018
6
0
10
0


I think it might be a issue of "POWER LIMIT THROTTLING" coz when I connect charger my CPU goes upto 2.3GHz and when I disconnect it it stays under 1.5GHz... Any suggestions?????
 
Jul 28, 2018
1
0
10
0


Did anyone get a solution to this? I am facing the same issue on my i7 8th Gen Laptop as well
 
Sep 8, 2018
1
0
10
0
I've dell laptop OK, i've the same problem and didn't know the reason of this problem, i tried to remove battery (run it as PC) it didn't work, my brother have the same model of my laptop i tried to get him laptop charger and connect it to my laptop it worked 100% as not plugged in
of course the reason is the charger. you should buy new one!
 
Nov 14, 2018
1
0
10
0
well you can try this out , it worked perfectly fine on my laptop
go to control pannel ,then to your applied battery setings,select advanced power settings and choose processor power management ,set your max plugged in processor state around 75~80% (78works best for me) you can fine tune it yourself seeing how it affect your game frame
 
Mar 28, 2019
1
0
10
0
Guys i am facing same problem i tried every method from here and from other forums nothing works my laptop is in fine condition i tried going to service center they said my laptop has nothing wrong with it and they cant say anything about games bcoz they are third party! my laptop is ASUS Fx series nvidia gtx1060 with 8 gb ram windows 10 for basic info! got cooling pad too so no heating issue there! i cant even play old games like fallout 4 or witcher 3 on low setting ! lag everytime i connect my charger! pls help
 
Thread starter Similar threads Forum Replies Date
mijo__ Laptop General Discussion 1
D Laptop General Discussion 1
BroA23 Laptop General Discussion 0
V Laptop General Discussion 4
J Laptop General Discussion 0
C Laptop General Discussion 0
L Laptop General Discussion 1
F Laptop General Discussion 4
S Laptop General Discussion 9
kol12 Laptop General Discussion 10
PCDesignerR Laptop General Discussion 6
J Laptop General Discussion 0
H Laptop General Discussion 2
S Laptop General Discussion 1
E Laptop General Discussion 3
C Laptop General Discussion 1
P Laptop General Discussion 1
A Laptop General Discussion 5
T Laptop General Discussion 8
C Laptop General Discussion 1

Similar threads


ASK THE COMMUNITY

TRENDING THREADS