Games always run with Intel instead of nvidia

Status
Not open for further replies.

Whispurrr

Commendable
May 24, 2016
3
0
1,510
0
Hello.. I need help here
My games won't run with nvidia, they always run with Intel instead. I can't find any fix from the internet so here I am. Most answers I read on the internet is "Go to nvidia control panel> go to manage 3D settings> click global settings> set preferred graphics proccessor to nvidia".
I've done that many times but still having the same problem right now.
This problem always happen after I reinstall my laptop (Windows 10) and I was always able to fix this... accidentally, and was able to play my games without a problem. Too bad I don't remember how to do that and cannot repeat my luck again.

These are my attempts to fix this :
- Optimize the games in nvidia geforce experience
- Open nvidia control panel, and switch my preferred graphic processor to "High-performance NVIDIA processor"
- Set my PhsyX processor to nvidia
- Right click on the game.exe and choose to run with nvidia (even if it says my nvidia is the default graphic processor)


My graphic processors :
NVIDIA Geforce GT 740M and
Intel HD 4000

I apreciate it if anyone can help me solve this issue.

PS : Sorry I'm not so good at computer and english.
 
Hi,

Please do try these troubleshooting steps that may help.
- First, go to Device Manager and uninstall the Nvidia graphics driver.
- Next is to open Programs and Features then uninstall anything related to Nvidia.
- Once uninstalled, download and install the latest driver.
- Here's the link: http://www.nvidia.com/Download/index.aspx
- Reboot the laptop once the latest driver has been installed and set Nvidia again as the default GPU.
- http://nvidia.custhelp.com/app/answers/detail/a_id/2615/~/how-do-i-customize-optimus-profiles-and-settings%3F
 
Hi,

Please do try these troubleshooting steps that may help.
- First, go to Device Manager and uninstall the Nvidia graphics driver.
- Next is to open Programs and Features then uninstall anything related to Nvidia.
- Once uninstalled, download and install the latest driver.
- Here's the link: http://www.nvidia.com/Download/index.aspx
- Reboot the laptop once the latest driver has been installed and set Nvidia again as the default GPU.
- http://nvidia.custhelp.com/app/answers/detail/a_id/2615/~/how-do-i-customize-optimus-profiles-and-settings%3F
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 1
K Laptop Tech Support 4
V Laptop Tech Support 5
D Laptop Tech Support 1
D Laptop Tech Support 10
C Laptop Tech Support 3
C Laptop Tech Support 3
W Laptop Tech Support 1
S Laptop Tech Support 6
S Laptop Tech Support 1
Samsamproducts Laptop Tech Support 2
S Laptop Tech Support 2
M Laptop Tech Support 5
Y Laptop Tech Support 2
M Laptop Tech Support 2
R Laptop Tech Support 2
LucaFire Laptop Tech Support 7
C Laptop Tech Support 6
D Laptop Tech Support 6
S Laptop Tech Support 2

ASK THE COMMUNITY