Games Lag when not on power

Frozenflame

Honorable
Jul 11, 2013
8
0
10,510
0
My computer lags when I run NFS:Most Wanted, Protoype 2 and Dishonored. I used to get much better frame rates but now it lags every 5-10 seconds or so. I own an ASUS S46CM. Here are the specs -

Intel Core i5 3317u
Nvidia GeForce GT635M 2 GB DDR3 RAM
6 GB 1600 Mhz DDR3 RAM

I would like to mention that this has happened after a system restore, which was done due to network problems. However, even though the network problems have gotten fixed, these new problems have arisen. Most importantly, I would like to mention that LAG GETS CURED WHEN PLUGGED IN.

Thanks
 

Kelthar

Honorable
Mar 27, 2013
16
0
10,570
4
Most likely because of windows profiles. When not on power, it reduces power consumption overall, and most likely cuts on the GPU or CPU.

Check it under the control panel, system, power.
 

Kelthar

Honorable
Mar 27, 2013
16
0
10,570
4
Most likely because of windows profiles. When not on power, it reduces power consumption overall, and most likely cuts on the GPU or CPU.

Check it under the control panel, system, power.
 

Frozenflame

Honorable
Jul 11, 2013
8
0
10,510
0


Thanks for the reply. However, I am unable to find the profile options or setting you have specified via the path provided or any other path for that matter.
 

Kelthar

Honorable
Mar 27, 2013
16
0
10,570
4
Which OS are you on? Windows 7? 8? 8.1?

Try right clicking on the battery or charger icon on the taskbar, since it's a laptop it should allow you to open the settings from there.
 

jaguarskx

Champion
Moderator
That is by design to help with battery life.

You can try modifying your Power Profile to improve performance, but it will likely not be the same as with the laptop plugged in. Go to control panel then click "System and Security". From there you should see "Power Options" and click it. From there:


1. Choose the power profile you are using or want to use like "High Performance", then click the "Change plan settings" link.
2. Click Change advanced power settings.
3. Show down to Processor Power Management and expand.
4. Expand the Maximum power state and change "On Battery" to 100%.

 

Frozenflame

Honorable
Jul 11, 2013
8
0
10,510
0

I am really sorry that I forgot to mention I am on Windows 8.
 

Frozenflame

Honorable
Jul 11, 2013
8
0
10,510
0


I already tried that and the thing is that it is already set on 100%, and changing power modes is not making a difference either.
 

jaguarskx

Champion
Moderator
Like I said, the laptop is designed to be that way to extend battery life. Nothing much you can do about it other than lower the settings when playing games while running on the battery. Buying a new laptop will not make a difference either since the new laptop will act the same way.
 

Frozenflame

Honorable
Jul 11, 2013
8
0
10,510
0


Thank you for the reply but what perplexes me is that my laptop didn't act in this manner before the system restore. Oh well, I guess it happens to everyone so there is no definite solution.

EDIT: Could the reason be my whole laptop getting to around 56 degree Celsiusfor around an hour or two? Would my battery be damaged by something of this sort?
 
Thread starter Similar threads Forum Replies Date
Irujezu Laptop Tech Support 2
E Laptop Tech Support 0
P Laptop Tech Support 1
M Laptop Tech Support 3
M Laptop Tech Support 1
W Laptop Tech Support 1
H Laptop Tech Support 5
A Laptop Tech Support 1
B Laptop Tech Support 3
Q Laptop Tech Support 3
B Laptop Tech Support 1
S Laptop Tech Support 5
R Laptop Tech Support 1
M Laptop Tech Support 1
K Laptop Tech Support 1
L Laptop Tech Support 1
P Laptop Tech Support 1
M Laptop Tech Support 6
J Laptop Tech Support 11
L Laptop Tech Support 2

ASK THE COMMUNITY