Google Chrome lags when scrolling (Windows 10)

apalio

Commendable
Apr 25, 2016
3
0
1,510
0
Google Chrome lags very bad while scrolling on most web pages. Also, sometimes videos played through the browser have poor FPS and are laggy. I know it is not my internet, as other browsers don't have an issue, and I'm hardwired with 150/75mbps speed.

I am on Windows 10 Anniversary Edition. I never had an issue while running on Windows 7 Ultimate. My machine is very powerful as well, so I'm narrowing it down for an issue with Chrome.

I have a lot of RAM, so I know that isn't an issue. I have HyperX Fury 32GB RAM, 2666MHz. Although, Chrome is using about ~200-550MB of RAM per tab, which seems high.

I'm not sure if there are any Windows 10 compatibility issues or not. I've done some searching but really haven't found much. Only thing I saw was to turn on smooth scrolling, which I tried. Unfortunately, it had no effect.

PC Specs:
GPU - EVGA GTX 980Ti (1102MHz, no overclock)
CPU - i7 6700k 4.0GHz (no overclock)
RAM - HyperX Fury 32GB 2666MHz
MOBO - ASUS Maximus VIII Formula Z170
Storage - HyperX Predator PCIe SSD 1.4GB/s read speed (for software, programs, a few games)
Driver - Nvidia 372.90 (newest)

Thank you in advance. I like Chrome, but unfortunately it has been running very poorly on W10, and I'm considering using a different browser because of it.
 

apalio

Commendable
Apr 25, 2016
3
0
1,510
0
I only use Adblock, SessionBuddy, Facebook Volume Sync and Stylish (makes websites have a dark theme). I also just got The Great Suspender, which actually helped out a noticeable amount. It suspends tabs that are idle for 5min.

However, it also lags in Incognito windows with no add ons. So I don't think it's the add ons.
 

Colif

Admirable
Moderator
this might help

In a new Chrome tab, paste the following into the address bar and then hit enter: chrome://flags/#disable-smooth-scrolling
Click the “Disable: link under “Smooth Scrolling”
Restart your browser
http://bgr.com/2016/03/18/fix-slow-chrome-browser-scrolling-lag/

a few suggestions: Chrome
 

apalio

Commendable
Apr 25, 2016
3
0
1,510
0
My very tech savvy friend told me to turn off hardware acceleration. So far it seems like it fixed it!

EDIT: I did try smooth scrolling on and off. One of the only suggestions that came up when I Googled it. Didn't help.
 
Thread starter Similar threads Forum Replies Date
R Apps General Discussion 0
N Apps General Discussion 2
T Apps General Discussion 7
P Apps General Discussion 1
Y Apps General Discussion 1
D Apps General Discussion 2
B Apps General Discussion 9
C Apps General Discussion 2
I Apps General Discussion 2
H Apps General Discussion 2
M Apps General Discussion 6
D Apps General Discussion 2
E Apps General Discussion 3
G Apps General Discussion 2
oathmark1 Apps General Discussion 3
I Apps General Discussion 2
W Apps General Discussion 5
S Apps General Discussion 4
Z Apps General Discussion 3
T Apps General Discussion 3

ASK THE COMMUNITY