Google Chrome not loading correctly.

DaronMal

Honorable
Sep 14, 2013
17
0
10,570
1
Recently I've been getting problems from Google Chrome, it's been acting weird a lot lately and I can't figure out why.

Sometimes Chrome will load slowly, and it'll sit there for minutes at a time until I cancel the loading, then reload the page. It always works the 2nd time when I refresh it, but about 40% of the time when i go to a new site or a new page it'll give me this issue.

Sometimes I get a blank error screen that says "This webpage is not responding". When I click "More" it says "Connection to (website) was interrupted" and gives the error code "ERR_CONNECTION_RESET"
 

CaptAli

Estimable
Mar 30, 2014
1
0
4,520
1
you really gotta have to check your connection, i used to get that when my internet connection was slow.
if you've got the fast one, just reinstall it then.
 

CaptAli

Estimable
Mar 30, 2014
1
0
4,520
1
you really gotta have to check your connection, i used to get that when my internet connection was slow.
if you've got the fast one, just reinstall it then.
 
Thread starter Similar threads Forum Replies Date
ChesterLane Apps General Discussion 1
R Apps General Discussion 0
N Apps General Discussion 2
T Apps General Discussion 7
P Apps General Discussion 1
Y Apps General Discussion 1
D Apps General Discussion 2
B Apps General Discussion 9
C Apps General Discussion 2
I Apps General Discussion 2
H Apps General Discussion 2
M Apps General Discussion 6
D Apps General Discussion 2
E Apps General Discussion 3
I Apps General Discussion 2
A Apps General Discussion 1
A Apps General Discussion 2
N Apps General Discussion 1
S Apps General Discussion 3
A Apps General Discussion 2

ASK THE COMMUNITY