Question HDD on Caddy does not work


Sep 28, 2013
Hello guys. I really need your help. Using a Windows 7 Home basic.
I bought a HDD Caddy around 3 days back and installed it into my laptop with a brand new 500 GB HDD and it worked after I installed it’s drivers and did a format of NTFS and did also transfer a few files to it from my Internal Laptop HDD to this new one and it worked flawlessly.
Just yesterday, I noticed that when I open Computer, it says Local Disk F(for my new HDD on the caddy) and does not open up. The space indicator showing ‘X out of X GB is free’ is also missing. When I double-click the Local Disk F, it really is slow and shows a progress bar which also moves very slow. The thing is it doesn’t open up and my computer literally freezes for a few seconds to a minute. When I open up the disk management from Computer>Manage, it doesn’t even load the disk management and show any of my installed HDDs. It just freezes. The thing is that it used to work perfectly fine until the last day and now all of a sudden this happens. Now, when I keep the HDD in caddy and restart the PC, it gets detected in BIOS and in the boot menu, and it will say Windows is loading, but after that the screen is blank. It won’t load the password screen. If I remove the caddy, it shows the password screen on restart.
What could be the issue? Any help would be definitely appreciated.
Thank You!