HyperX Cloud 2 Microphone Problems

Conrado_

Commendable
Mar 11, 2016
2
0
1,520
1
Hello.
I recently bought the Hyper X cloud II headset. The headphone themselves work fantastic but the problem I have lies with the microphone. Whenever I try to talk to my friends on skype, they complain of a constant buzzing/humming noise coming from my microphone. I tried to resolve it and it seems the only time the buzzing stops is when I put my full hand on my computer case. I did some more research and some people said its due to a bad ground loop or something like that. I am 16 and have no clue what any of that means so if somebody can clarify this and help me rectify the problem I would greatly appreciate it. Thanks in advance.
 

Conrado_

Commendable
Mar 11, 2016
2
0
1,520
1
For the random person who may have this same problem and frustration as I had. I found the answer. It was so simple and I really realize how stupid I was after all the frustration. Just unplug your power cord and plug it back in. Worked for me.
 

Conrado_

Commendable
Mar 11, 2016
2
0
1,520
1
For the random person who may have this same problem and frustration as I had. I found the answer. It was so simple and I really realize how stupid I was after all the frustration. Just unplug your power cord and plug it back in. Worked for me.
 
Thread starter Similar threads Forum Replies Date
Szaszakk Audio 0
S Audio 3
K Audio 1
X Audio 1
A Audio 8
M Audio 1
M Audio 1
L Audio 3
J Audio 1
O Audio 3
N Audio 2
J Audio 1
U Audio 1
A Audio 2
T Audio 6
Brogni Audio 1
M Audio 2
A Audio 1
U Audio 3
R Audio 2

ASK THE COMMUNITY