Question Hysteresis (Backlash) Excessive on Synaptics Touchpads

eugbug

Distinguished
May 28, 2009
8
0
18,510
0
I have a 2018 model Lenovo Y530 Laptop. There is quite a lot of hysteresis on the touchpad (3 to 5mm). Has anyone experienced this and resolved the issue? I tried installing a new driver, but it didn't solve the problem. Not sure if firmware has to be changed too?
 
Last edited:
Try starting up in "Safe Mode" and see if you get the same problem. If you do, then it is likely a hardware issue and needs to be looked into. If the laptop is under warranty, then I would contact the manufacturer, if not, a local tech.

However, if it works fine in "Safe Mode" then it is likely software. Malware, virus, bad app, other program interfering with the actions, etc. Then you need to check the computer for all those things.

Additionally, if your device uses one, you may want to try updating the Synaptics Driver if the above doesn't help.

How to enter "Safe Mode" when booting the computer.

In Windows 8 and 10...

As your computer restarts, press F8 (possibly a few times) to enter "Safe Mode"

a. Press the "F4" key to Enable "Safe Mode".
(The computer will then start in "Safe Mode" with a minimal set of drivers and services.)

b. Press the "F5" key to Enable "Safe Mode" with Networking.
( Once "Safe Mode" with Networking starts, Windows is in Safe Mode, with additional network and services for accessing the Internet and other computers on your network.)

c. Press the "F6" key to Enable "Safe Mode" with Command Prompt.
(In "Safe Mode" with "Command Prompt" starts Windows in Safe Mode, with a Command Prompt window instead of the Windows interface. This option is mostly only used by IT professionals.)

Now sign in to the computer with your account name and password. (If you have one set.) When you are finished troubleshooting, you can exit "Safe Mode" restarting your computer.

In Windows 7/Vista/XP...

1. Immediately after turning on the computer, or restarting it (usually after you hear your computer beep), tap the F8 key, repeatedly, in 1 second intervals.

2. The computer will then display hardware information and run a memory test.

3. Next the "Advanced Boot Options" menu will appear.

4. In the "Advanced Boot Options" menu use the arrow keys to select "Safe Mode" or "Safe Mode with Networking" and press ENTER.
 

eugbug

Distinguished
May 28, 2009
8
0
18,510
0
Try starting up in "Safe Mode" and see if you get the same problem. If you do, then it is likely a hardware issue and needs to be looked into. If the laptop is under warranty, then I would contact the manufacturer, if not, a local tech.

However, if it works fine in "Safe Mode" then it is likely software. Malware, virus, bad app, other program interfering with the actions, etc. Then you need to check the computer for all those things.

Additionally, if your device uses one, you may want to try updating the Synaptics Driver if the above doesn't help.

How to enter "Safe Mode" when booting the computer.

In Windows 8 and 10...

As your computer restarts, press F8 (possibly a few times) to enter "Safe Mode"

a. Press the "F4" key to Enable "Safe Mode".
(The computer will then start in "Safe Mode" with a minimal set of drivers and services.)

b. Press the "F5" key to Enable "Safe Mode" with Networking.
( Once "Safe Mode" with Networking starts, Windows is in Safe Mode, with additional network and services for accessing the Internet and other computers on your network.)

c. Press the "F6" key to Enable "Safe Mode" with Command Prompt.
(In "Safe Mode" with "Command Prompt" starts Windows in Safe Mode, with a Command Prompt window instead of the Windows interface. This option is mostly only used by IT professionals.)

Now sign in to the computer with your account name and password. (If you have one set.) When you are finished troubleshooting, you can exit "Safe Mode" restarting your computer.

In Windows 7/Vista/XP...

1. Immediately after turning on the computer, or restarting it (usually after you hear your computer beep), tap the F8 key, repeatedly, in 1 second intervals.

2. The computer will then display hardware information and run a memory test.

3. Next the "Advanced Boot Options" menu will appear.

4. In the "Advanced Boot Options" menu use the arrow keys to select "Safe Mode" or "Safe Mode with Networking" and press ENTER.
Ok, thanks will try that. On some Linux forums, I have seen people discussing the hysteresis issue and apparently it's possible to change it by programming. By default it's excessive.

Example forum post:
https://www.reddit.com/r/archlinux/comments/6as7bk View: https://www.reddit.com/r/archlinux/comments/6as7bk/removing_dead_zone_from_touchpad_when_performing/
 
You could check the settings for the Synaptics in Windows. Not been in there in a while so cannot remember if it has the same access through Windows itself. I personally don't care for touchpads. Prefer a mouse. But I know it would not be normally set to jump that much. I know many artists who use touchpads and that would be a nightmare for them. I would never hear the end of it. :) And not had that happen, so It wouldn't be normal.
 

eugbug

Distinguished
May 28, 2009
8
0
18,510
0
You could check the settings for the Synaptics in Windows. Not been in there in a while so cannot remember if it has the same access through Windows itself. I personally don't care for touchpads. Prefer a mouse. But I know it would not be normally set to jump that much. I know many artists who use touchpads and that would be a nightmare for them. I would never hear the end of it. :) And not had that happen, so It wouldn't be normal.
I don't normally use a touchpad either, just when I'm away from a desk. It's practically useless when drawing any graphics.
 

ASK THE COMMUNITY