I bought a Gaming Laptop two days ago and have been having some very unique and very irritating problems with the GPU

Dec 23, 2018
2
0
10
0
Now before I delve into the problem, I will detail the specs of the laptop.

It is an Acer Nitro 5 fitted with

CPU - Intel i7-8750h
Display 1 - Intel(R) UHD Graphics 630
Display 2 - GTX 1060
Ram - 16gbs

The issue I had before was that it seemed every game I played with this laptop was running on the integrated graphics card, the 630, this led to every single game no matter what settings I had it on, ran on 20 - 30 fps. However I did go into the NVIDIA control panel and switched it to the high processor, the 1060. After restarting the first time I did this it was heaven every game I played ran as it should 60 - 90 fps on ultra settings.

Anyway this is where the problem arouse, I turned it on the next day and to my avail, the same issue was happening every game I played ran on 20 - 30 fps. I checked the control panel, still set to the settings I had, I checked what was running on the 1060, the game was there. I shut it off out of anger and here is where the unique thing happened, I turned it on again later in the day and every game ran as it should, I enjoyed that for a while switched it off and after having it on sleep to get some lunch, 20 - 30 fps on everything.

I have no idea why it is doing this, sorry for rambling and I hope anyone out there can help me with this problem,

Thanks!
 
Dec 23, 2018
2
0
10
0


I found out that the laptop is set to use the 1060 when only plugged in, i'm unsure if there's a way to have it use it on battery life as well
 

Similar threads