I have a HUGE Problem with Java - please help

Sir Arun

Distinguished
Jul 12, 2009
6
0
18,510
0
I did a clean install (as administrator) of the 32-bit "Java 7 Update 17" by installing the .exe file called "JavaSetup7u17.exe" from the oracle website.

(you and I both know how there are crap loads of files that you can download from the Oracle website, most of them older versions of java, but then also some confusing ones such as "jxpiinstall.exe", the runtime environment (JRE), the development kit (SDK), java virtual machine (JVM), the J2SE, the Java SE 6, and whatnot....)


Anyways, here is the thing: I run Windows 7 64-Bit Home Premium, I use Firefox 19.0.2 and IE 10.0.9200.16521 as my browsers.

On Firefox, if I go to the Java test page (http://www.java.com/en/download/testjava.jsp), it detects my Java version without problems.


But if I load the exact same page on IE10, I get the message:

"No working Java was detected on your system.
Install Java by clicking the button below."

...and clicking the red button below that, takes me to the same page which let me download and install JavaSetup7u17.exe in the first place (see first sentence of this post)


=========================


Moving on, there is more funny things going on:

On my 64-bit system, Java 6 used to install in the folder called "Program Files". Java 7 now installs in the "Program Files (x86)" folder.


That being said, Java also used to put a copy of the java.exe, javaw.exe and one other javaws.exe in the Windows/System32/ folder

SO, if I opened up cmd (the black box) as administrator and typed

java -version

...it would search this folder for java and then tell me the version.

Well, funny thing is, Java 7 has no java files installed in the System 32 folder.

So by typing java -version in the cmd, I get a fail. (EDIT: I corrected this by copying the java.exe from my program files to windows/system32 and dropping it there. Now I can correctly check the java version with cmd)

Last but not least, I cannot open .jar files and .jnlp files even if I right click on them and select the Java.exe app to open them with - I get a black box for the fraction of a second and then it disappears when i double click the files.


I have made sure that the "scripting of java applets" in the internet security settings of IE10 is set to enabled, but to no avail.

I have made sure that in the Control Panel, under Java, under security settings, there is a tickmark on the "Java-content is activated in browsers" option.

I have also done this (clearing Java cache): http://www.java.com/en/download/help/plugin_cache.xml?


...but to no avail. I am completely out of ideas, as I simply C-A-N-N-O-T open .jar files or .jnlp files right now :/

Please help me out.

EDIT: I also tried installing the "offline version" called "jre-7u17-windows-i586.exe". Also didnt work and have the same situation as above.
 

MC_K7

Distinguished
Aug 31, 2008
74
0
18,610
12
It might sound like a silly question but since your OS is 64-bit, by default it might open the 64-bit version of IE10? If you open IE10 32-bit do you still have the problem?

Or another way to fix things would be to install both versions of Java (32-bit + 64-bit), that's what I usually do on 64-bit OS.

IE10 is rather new and has been plagued with bugs so far (kind of expected during the first months of use for new products) so if you can't solve your problem I would suggest to downgrade to IE9 which was pretty stable. Or since you say Java is working fine under Firefox, you could also use only Firefox for your Java needs for a while until they solve problems with IE10.
 

lovesX79

Honorable
Mar 11, 2013
1
0
10,510
0
you are mixed up about the 32bit version which is X86 and the 64bit version, the 64bit version is 6.XX and the 32bit version is 7.XX, if I was you uninstall all versions, manually download both versions of java, install the 32bit version first offline, IE 10 is not 64bit yet
 

Dogsnake

Distinguished
Oct 20, 2006
99
0
18,610
24
By default FireFox (I do not use IE much but I think this goes for Ver.10 as well) does not install the JAVA plug in. Major security issues have been found in that hackers can use the JAVA extension to infiltrate systems (reference: http://www.reuters.com/article/2013/01/11/us-java-security-idUSBRE90A0S320130111 and https://blog.mozilla.org/security/2013/01/11/protecting-users-against-java-vulnerability/). I removed JAVA to see what effect it would have on my browsing, and I have not found any issue or restrictions. There are a few items like DSL Report's Tweak Test that require it. I also run the Nightly version of FF 64bit currently in development. No issues there. I suggest you completely remove all versions of JAVA. Then, if you must have JAVA and are using the latest FF release (it is 32 bit) go to (http://www.oracle.com/technetwork/java/javase/downloads/index.html) and download the 7u17 JAVA version. If you run the in development 64 bit version you will need the 64 bit JAVA for that version of the browser as the 32 bit plug in does not work in the 64 bit browser. Hope this helps.
 
Thread starter Similar threads Forum Replies Date
P Apps General Discussion 4
I Apps General Discussion 2
kikani.kautik Apps General Discussion 2
S Apps General Discussion 5
D Apps General Discussion 1
S Apps General Discussion 1
L Apps General Discussion 0
P Apps General Discussion 1
F Apps General Discussion 1
A Apps General Discussion 5
H Apps General Discussion 0
S Apps General Discussion 1
henrytcasey Apps General Discussion 2
P Apps General Discussion 1
A Apps General Discussion 1
B Apps General Discussion 0
reble Apps General Discussion 0
S Apps General Discussion 1
V Apps General Discussion 1
S Apps General Discussion 8

Similar threads


ASK THE COMMUNITY