I upgraded my andorid version to higher but I still cant install apps that required higher android version than my old.

skumbagfluffy

Honorable
Jan 26, 2014
4
0
10,510
0
Pretty much as the title says,i have a smartphone with 2,3,6 android version(ZTE kis plus) and I changed it to 4,2,2 but I cant install apps such as Google chrome which requires an android version of 4 and up.Why is that
 

AkshatG

Estimable
Feb 26, 2014
11
0
4,570
4
You can try updating the google play services first and then try to install the applications.. I am positive this shud work...it worked for me previously. thanks :)
 

rohn_avni

Distinguished
Jul 8, 2010
16
0
18,570
3
As you mentioned that your phone was on 2.3 so I don't think it's a 4.2.2 Official update.. it means you have flashed a custom rom for sure. just check whether that rom is actually based on JB or just a build.prop edit showing you the ver as 4.2.2
 
Thread starter Similar threads Forum Replies Date
B Android Smartphones 1
S Android Smartphones 3
H Android Smartphones 1
S Android Smartphones 1
L Android Smartphones 1
S Android Smartphones 1
L Android Smartphones 6
C Android Smartphones 2
G Android Smartphones 0
B Android Smartphones 1
J Android Smartphones 1
G Android Smartphones 0
R Android Smartphones 1
G Android Smartphones 0
G Android Smartphones 0
C Android Smartphones 1
Graybush Android Smartphones 1
L Android Smartphones 2
L Android Smartphones 1
T Android Smartphones 1

ASK THE COMMUNITY