Internet connection not working in Google Chrome

Erikkui

Estimable
Jul 30, 2015
2
0
4,510
0
Recently, Google Chrome has stopped loading any pages. I can open History and "new tab" pages , but I'm unable to go to any real website. Other browsers work just fine, only Chrome is bugging. Voice chats and internet games work too.
I'm able to use Chrome for some 20-60 minutes, then it just all of a sudden stops working. It infinitely loads pages, with that spinning ring in the left side of tab grey. So far only working "fix" for this has been rebooting computer. Some times it starts working again, but I don't know what causes it.

Update: Apparently, browsing incognito works normally.
 

Erikkui

Estimable
Jul 30, 2015
2
0
4,510
0
I went to options and from there to "About" tab. It says Chrome is up to date. Anyways, the version I'm using is 52.0.2743.116 m.
I also use my phone's shared internet connection, if that helps anything.
 
Thread starter Similar threads Forum Replies Date
D Apps General Discussion 0
D Apps General Discussion 7
T Apps General Discussion 1
A Apps General Discussion 10
O Apps General Discussion 1
shivampandit1999 Apps General Discussion 4
R Apps General Discussion 5
J Apps General Discussion 1
A Apps General Discussion 1
J Apps General Discussion 4
A Apps General Discussion 1
F Apps General Discussion 2
P Apps General Discussion 3
A Apps General Discussion 1
V Apps General Discussion 1
My Life Is Tech Apps General Discussion 2
P Apps General Discussion 3
J Apps General Discussion 1
N Apps General Discussion 11
G Apps General Discussion 4

ASK THE COMMUNITY