Issue with all gaming mouse with Asus rog G751JL 17in

Status
Not open for further replies.

PC Keepsie

Commendable
Sep 15, 2016
2
0
1,510
0
Ok please bare with me on this one. Im having issues with getting any gaming mouse to aim correct on this laptop. In CoD Blops3 lets use example of a dot on the wall. On my normal Desktop rig or any other computer i can turn around and aim at that dot perfect. But on the laptop if i try to aim at the dot my aim will jump/slide and feel off. I will end up aiming at that dot but by that time in game im already dead. Anyone who uses a mouse for years will knows the off im talking about just doesn't feel right.

Mouse's i use. Logitech g303 & Logitech g100s I have 2 each. Also Black-web gaming mouse just for testing (2). DPI 800. Im on windows 10 pro

What i have tried: I have installed latest software for graphics drivers. Lowered graphics and even went down to 720p to make sure FPS wasn't a issue. I have checked and made sure no mouse acceleration was on both Logitech software and in windows mouse config. Im on windows 10 and i have cleaned installed twice. Installed drivers and tried with only game. Issue is still there.

This is only pc i ever had this issue on and im starting to think there is motherboard hardware issue. I tested with 3 Macs 13in 15in and mac mini. My main rig titan x and i7-4790k. and my kids amd a6 computer aim is fine with all these pcs.

Any suggestions would be very helpful. If not i will just have to get rid of this laptop. ty
 
Status
Not open for further replies.

ASK THE COMMUNITY