Kingston HyperX Cloud II sounds awful.

GameSlice

Estimable
Aug 5, 2015
1
0
4,510
0
I recently purchased a Kingston HyperX Cloud II gaming headset after hearing a huge amount of praise for it. It replaced my Razer Kraken Pro, as it had a broken cable. I plugged it in, followed the instructions and played some audio. It sounds terrible and distorted. Distant, too. It may have something to do with Razer's Synapse audio controller, but I turned that off and it still sounded terrible. The cable is fine and all the connections are secure, but I can't figure out why it isn't transmitting properly. I'm using a USB connection on Windows 7. I'd appreciate any help. Thanks.
 

ssddx

Glorious
Moderator
the first thing i'd try doing is to not use the usb soundcard that came with it.

try plugging in with 3.5mm to your pc. if it still sounds bad try plugging into your phone and other devices. does it sound the same?

if you have a razer headset you likely have razer virtual surround. not sure if that is acting up with the included virtual surround on the usb soundcard included with the hxc2 or not which is why i asked you to test on multiple devices to get a feel for if you just dont like the sound of the headphones or if its an issue with your pc/usb soundcard.
 
Thread starter Similar threads Forum Replies Date
B Audio 3
R Audio 4
F Audio 2
R Audio 1
O Audio 2
M Audio 2
N Audio 2
metalhusky Audio 3
C Audio 7
P Audio 4
T Audio 1
Awesomlego Audio 1
D Audio 1
R Audio 1
S Audio 2
Z Audio 1
B Audio 10
U Audio 5
F Audio 4
X Audio 3

ASK THE COMMUNITY