Laptop not using dedicated gpu

bassel yousry

Estimable
Aug 9, 2014
3
0
4,510
0
Wassup,
I recently got the lenovo IdeaPad 320
Which has an amd 530 graphics card
Plus an intel hd 620 onboard graphics
I installed windows 10 on this laptop and installed the latest intel and amd graphics drivers
But whenever i try to play a game it automatically runs on the intel you onboard graphics, i couldnt get it to run on the amd gpu
I installed gpu-z and saw that the usage of the amd gpu was 0% and i also found out about that when i saw that the gpu activity was 0% on the amd monitoring thing
Things I've tried :
-Intalling the latest amd and intel gpu drivers after using ddu and amd clean up utility in safe mode
-updating bios
-adding games to the amd graphics program and switching to high performance mode
If you could help me it'd be really nice
 
First you need to get it to detect and use the right card.

A. Uninstall, and then reinstall, the latest graphics card driver.
B. Make sure that your AMD graphics card is set as the default graphics card.

Here's the steps on how to set it to default.

1. Open the "Control Center".
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance AMD processor.

Once it is running on the right one, test the system again and see if the problem persists.


For ATI/AMD graphics cards the process varies.

You may need to open graphics then PowerPlay and set plugged in and/or battery to maximize performance.

You can also try going to graphics then 3D and move the slider to performance. Your computer may also have a switchable graphics tab where you can change the settings for individual programs.
 

bassel yousry

Estimable
Aug 9, 2014
3
0
4,510
0
Hey webworkings that down vote was and accident btw
Sorry
So i need you to tell me how to access power play since the new driver doesn't have that
I've already tried adding programs and choosing high performance but it didn't have any affect
 

bassel yousry

Estimable
Aug 9, 2014
3
0
4,510
0
Webworkings
Sorry for the late reply
But i really want to thank you
I rolled back my driver to version 16.9.1
And it worked !
So thank you for your time
 
Thread starter Similar threads Forum Replies Date
A Laptop Tech Support 1
B Laptop Tech Support 1
K Laptop Tech Support 3
Ghaffar.dosti Laptop Tech Support 3
S Laptop Tech Support 1
T Laptop Tech Support 2
E Laptop Tech Support 1
T Laptop Tech Support 14
P Laptop Tech Support 3
V Laptop Tech Support 5
A Laptop Tech Support 3
Y Laptop Tech Support 3
H Laptop Tech Support 2
A Laptop Tech Support 1
B Laptop Tech Support 1
T Laptop Tech Support 9
A Laptop Tech Support 2
M Laptop Tech Support 2
F Laptop Tech Support 8
N Laptop Tech Support 4

ASK THE COMMUNITY