Laptop wont boot from SSD after HDD is connected

BK-201

Commendable
Jun 16, 2016
2
0
1,520
1
Hi, my bios recognize the HDD from my HP Envy 15 laptop as the main drive always and i want to install Windows on a secondary M2 SSD

when im on UEFI mode i cant install the OS because no drive is detected by the W8 installation, when i switch to legacy i can do it but as soon as i reconnect the HDD the bios tell me no boot device found

the problem is that the bios gives the HDD priority over the SSD by default and there's no way to change that setting in the bios, i made this work i while ago but i got my laptop repaired (new motherboard) and after updating the bios the problem started again, i know i fixed it with diskpart and messing around with some commands in CMD but i cant remember how i did so
 

BK-201

Commendable
Jun 16, 2016
2
0
1,520
1
i find the solution myself (just like the first time) so whoever who's having the same problem as i please try this

Problem: my laptop only have 2 ports, 1 for sata hdd and one for m2 ssd, consequently HDD sata port will always be Disk 0 but you want to install the OS in the M2 SSD or disk 1 but you cant change the boot order to prioritize the SSD over the rest because the options in the bios are limited

first of all i used Rufus to create a bootable USB with a GPT partition and FAT32 format, i booted the usb ad went to the repair option, then troubleshoot and then command prompt, there i used diskpart to clean the HDD and leave it un-allocated, i also converted the SSD to GPT with the convert to gpt command in diskpart

finally installed Win8 on the SSD and booted to it, everything works fine until i change the bios back to UEFI, before doing that please start up your OS and install all the remaining drivers otherwise you'll get an BSOD with inaccessible boot device, Open device manager and check if there are devices with a yellow exclamation sign, if so go to your laptop's manufacturer site and download the drivers (look for a storage drivers), install them and change the bios back to UEFI

all works fine now, HDD for data and SSD for OS, i also checked msinfo32 to see in the system got installed in legacy mode and it says UEFI so no problem there either

i hope this helps


 

SuperSoph_WD

Estimable
Jul 30, 2014
168
0
4,910
83
Welcome to Tom's Hardware, BK-201!

I'd recommend you attempt to resolve the issue by resetting BIOS from the settings first. If you are not able to set the boot priority properly afterwards, you might want to check these commands for CMD from the MS tech support website.

If that doesn't help, repeat the clean install of Windows onto the M.2 SSD while keeping the HDD unplugged from the laptop. If you have access to another computer, you might as well backup the data from the hard drive there and re-format it from Disk Management.

Here's a thread you might find useful as well.

Good luck! Hope it helps! :)
SuperSoph_WD
 

BK-201

Commendable
Jun 16, 2016
2
0
1,520
1
i find the solution myself (just like the first time) so whoever who's having the same problem as i please try this

Problem: my laptop only have 2 ports, 1 for sata hdd and one for m2 ssd, consequently HDD sata port will always be Disk 0 but you want to install the OS in the M2 SSD or disk 1 but you cant change the boot order to prioritize the SSD over the rest because the options in the bios are limited

first of all i used Rufus to create a bootable USB with a GPT partition and FAT32 format, i booted the usb ad went to the repair option, then troubleshoot and then command prompt, there i used diskpart to clean the HDD and leave it un-allocated, i also converted the SSD to GPT with the convert to gpt command in diskpart

finally installed Win8 on the SSD and booted to it, everything works fine until i change the bios back to UEFI, before doing that please start up your OS and install all the remaining drivers otherwise you'll get an BSOD with inaccessible boot device, Open device manager and check if there are devices with a yellow exclamation sign, if so go to your laptop's manufacturer site and download the drivers (look for a storage drivers), install them and change the bios back to UEFI

all works fine now, HDD for data and SSD for OS, i also checked msinfo32 to see in the system got installed in legacy mode and it says UEFI so no problem there either

i hope this helps


 
Thread starter Similar threads Forum Replies Date
geriuu Laptop Tech Support 3
R Laptop Tech Support 3
V Laptop Tech Support 1
Chael Orallo Laptop Tech Support 1
J Laptop Tech Support 0
sulphur88 Laptop Tech Support 1
N Laptop Tech Support 3
miluti Laptop Tech Support 3
LifeIsAFairyTail93 Laptop Tech Support 1
E Laptop Tech Support 2
T Laptop Tech Support 1
D Laptop Tech Support 0
S786 Laptop Tech Support 1
B Laptop Tech Support 2
D Laptop Tech Support 4
A Laptop Tech Support 0
R Laptop Tech Support 0
rahulkumarbudhwani Laptop Tech Support 1
AverageWhiteGirl Laptop Tech Support 1
anonymous30 Laptop Tech Support 1
Similar threads
Question Connect 144hz monitor per docking station to laptop
Question Trying to connect laptop to tv through hdmi
Question Can't connect laptop to an external display through normal HDMI
Question Laptop won't turn on (old and new battery) but turn on when the battery is removed and connected to Ac adapter
Question Possible? Dual monitors with two different laptops connected to ThinkPad ThunderBolt port replicator
Question External monitor black screen when connected to my laptop HDMI port
Question Laptop high ping and poor connection when other devices is fine
Question HP Notebook 17-x010ca was dropped 3ft onto a rug; backlight works, but no picture. Everything else seem to work when connected to an external monitor.
Question Unable to Connect Laptop to TV with HDMI
Question Can not open 192.168.1.1 or any other IP addresses (inside Network) + no Network discovery
Question Toshiba Laptop charger connects and disconnects
Question ACER E5-571 no screen or lights. low running noise
Question Hp Laptop connection to Barco Monitor
Question Laptop connects to WiFi but can't access internet
Question Laptop connects to wifi, then disconnects and crashes shortly after.
Question Laptop HDMI connection to projector & HDTV display problems
Question Toshiba Satellite Radius 12 P25W - C2300 - 4K constant freezeing / reboot when connected to AC
Question Laptop Freezes or wifi gets disconnected and unable to connect to new wifi hotspot when laptop is moved
Question windows 7 laptop wont connect to a network, all other devices will
Question Charger blinks when connected to Laptop

ASK THE COMMUNITY