Solved! Lenovo IdeaPad 700 display problems

Erki11

Commendable
Apr 5, 2016
8
0
1,510
0
First of all sorry for my bad english, yesterday I was just watching film on my notebook, today when I turned it on my display was completely broken almost whole display was black with some shadows and vertical lines. I was scared so I connected it to my pc monitor and backed up everything to my external hdd. First 5 minutes I was not able to do anything nothing was responding then I was able to move my school projects to external hdd, while I was doing it display on notebook started to work partially. Display was working but it was flickering, after 15-20 minutes display on notebook was working like nothing happened. I dont know what is going on, notebook is not in warranty anymore so I decided to check if display is connected correctly to motherboard, everything looks fine. Now when I turn on notebook it works but when Im moving with display sometimes it flicker or something like that. Im adding video of my notebook display. Thank you for your patiency and every advice. [video="https://www.youtube.com/watch?v=kzqhe1zDyPQ&feature=youtu.be"][/video]
 
It could be the display itself, or it could be the cable that connects the display. Personally I would be leaning towards the cable. Either the end connected to the display or the end connected to the motherboard could be loose. It also could be being pinched or bent somewhere inside (the cable that is) which would explain it changing as you move it. Now this can also happen with the display, changing as you move it, but I would start with the cable.
 

Erki11

Commendable
Apr 5, 2016
8
0
1,510
0
I was checking the cable from display if it is connected correctly and everything was right, I unpluged it and pluged it in but the problem is still there. nothing seemed pinched, I can unscrew bottom and send photos
 

Erki11

Commendable
Apr 5, 2016
8
0
1,510
0
I did it only with end that connects to motherboard I dont know where is other end I will try to find some video that shows it
 

Erki11

Commendable
Apr 5, 2016
8
0
1,510
0
I really dont know what to do... I found the problem, cable behind screen is loose but it is because it is holding only with tape from factory...I have tried to use new tape but it doesnt hold on place
 
Thread starter Similar threads Forum Replies Date
MasterLewis Laptop Tech Support 1
S Laptop Tech Support 3
L Laptop Tech Support 8
eslam0stafa23 Laptop Tech Support 1
GISdude Laptop Tech Support 4
Ruve Laptop Tech Support 2
C Laptop Tech Support 1
navidelip Laptop Tech Support 1
N Laptop Tech Support 1
L Laptop Tech Support 5
T Laptop Tech Support 1
M Laptop Tech Support 6
babu566 Laptop Tech Support 5
w00zyy Laptop Tech Support 5
niv_p Laptop Tech Support 3
XoTatianaa Laptop Tech Support 1
matwes Laptop Tech Support 3
A Laptop Tech Support 1
C Laptop Tech Support 2
G Laptop Tech Support 4

ASK THE COMMUNITY