Lenovo Legion Y520 GPU problems

Nov 15, 2018
2
0
10
Best answers
0
Hi everyone!

So my Y520's 1050 TI has been acting strange lately. Whenever I do something, whether that be CAD work or games, that requires more GPU usage, the program would freeze up or crash and then my Nvidia control panel wouldn't display the GPU as if it was disconnected. I keep all my drivers up to date and mostly use it for CAD work and some games whenever I'm not near my main rig.

Has anyone else had this or a similar problem? If this is a case of a dead GPU, is there a way to disable the 1050 TI permanently and solely use Intel HD?
 
Nov 15, 2018
2
0
10
Best answers
0


Yeah it's been out of warranty for a few months now unfortunately and sending it it will probably cost as much as getting a new computer. I've been disabling it through device manager, but it will reenable every time I restart the computer.
 
Thread starter Similar threads Forum Replies Date
B Laptop General Discussion 1
S Laptop General Discussion 1
E Laptop General Discussion 0
F Laptop General Discussion 0
Z Laptop General Discussion 0
S Laptop General Discussion 0
L Laptop General Discussion 0
P Laptop General Discussion 2
V Laptop General Discussion 0
E Laptop General Discussion 8
S Laptop General Discussion 2
bilyyjones Laptop General Discussion 1
M Laptop General Discussion 1
G Laptop General Discussion 2
M Laptop General Discussion 1
Z Laptop General Discussion 3
W Laptop General Discussion 1
P Laptop General Discussion 2
D Laptop General Discussion 1
M Laptop General Discussion 8

Similar threads


ASK THE COMMUNITY