Question Lenovo Y530 suddenly became incredibly slow, continues to be after Windows reinstall

Mar 30, 2020
1
0
10
0
I have a Lenovo Y530 for 15 months now (i7-8750H, 1050Ti, 32GB RAM, SSD+HDD onboard). Some days ago the computer suddenly became incredibly slow, I can't even scroll on a webpage without it lagging, and it has major problems doing basic Photoshop tasks or even light gaming. I suspected I might have gotten some malware that does this, so I reinstalled. Twice. Only slight improvements. It's weird, I start a game that normally would run on Ultra settings, it almost runs flawlessly, but when I turn down the graphics to minimum, the fps doesn't improve at all. The computer is overall significantly slower than before. Previously I had a cooling issue which had been fixed by swapping the ventilators at warranty. It's not running hot, the CPU usage in the Task Manager is usually at 20-25%. What could cause the problem? I have all drivers installed correctly. I fear this might be a GPU issue. Or is this just some aggressive malware? Any help appreciated!
 
Thread starter Similar threads Forum Replies Date
Semilore kaj Laptop Tech Support 0
D Laptop Tech Support 1
I Laptop Tech Support 7
S Laptop Tech Support 13
S Laptop Tech Support 2
J Laptop Tech Support 5
M Laptop Tech Support 1
P Laptop Tech Support 7
C Laptop Tech Support 3
Y Laptop Tech Support 1
G Laptop Tech Support 1
S Laptop Tech Support 6
M Laptop Tech Support 1
P Laptop Tech Support 2
A Laptop Tech Support 1
S Laptop Tech Support 1
W Laptop Tech Support 3
D Laptop Tech Support 1
aqk Laptop Tech Support 7
S Laptop Tech Support 1

ASK THE COMMUNITY

TRENDING THREADS