Logitech G430s Get No Sound From Applications

Status
Not open for further replies.

redwoodclimber

Estimable
Nov 16, 2014
1
0
4,510
Okay, so for the past couple of months my headset has been acting up (suspecting Windows 10). The sound works with windows (i.e. when I press the volume mixer it makes a sound) but not with any program like chrome or steam. The only fix I've found is to go into Device Manager --> Sound, Video, game controllers --> Logitech G430 Gaming Headset, right click and uninstall every time I start up the computer. Then unplug and plug back in and restart any programs that are for the sound to work. It's become too much of a hassle, so if anyone knows how to fix this of if this is also happening to them, please let me know. Thanks!
 
Solution
-Make sure that your Firmware is updated. Go to the Logitech Gaming Software -> Settings -> G430 -> Update if possible.

-When you are playing music or sound, whatever with Chrome, Steam etc. do you recieve the 'signal' that there is sound? In the volume mixer you should see chrome (if you are using chrome at the moment) if you get sound from chrome the green bar shoud go up.

-Check if the Logitech G430s is set as standard device.

This are the only things you can try that came up in ma head now ..

Grusek

Estimable
Feb 5, 2016
3
0
4,520
-Make sure that your Firmware is updated. Go to the Logitech Gaming Software -> Settings -> G430 -> Update if possible.

-When you are playing music or sound, whatever with Chrome, Steam etc. do you recieve the 'signal' that there is sound? In the volume mixer you should see chrome (if you are using chrome at the moment) if you get sound from chrome the green bar shoud go up.

-Check if the Logitech G430s is set as standard device.

This are the only things you can try that came up in ma head now ..

 
Solution
Status
Not open for further replies.