Solved! Logitech H111 Mic does not work on my Dell Laptop

Dec 11, 2018
3
0
10
0
First of all, I commend Logitech for its clear and crisp sound. However, my headset's mic does not work on my Dell laptop. It works perfectly on my smartphone and ipad but not on the laptop. I tried calling Dell Support if they could provide any solutions, instead, they gave me a generic answer from google saying that the headset has the problem. I strongly disagree though because it works on other devices. I hope someone has the it intelligence greater than Dell Customer Support agents to help me with this problem. I have struggled with this dilemma for almost a year now.
 
It is possible that the place you are connecting it is either output only, which will not work with a headset/mic as it needs an input/output to work. Or the port isn't working correctly in the laptop. Which happens a lot. I would try checking to make sure if it is output only or not first. Then, if it is both, try another headset in it to see if that works. If it turns out to be output only, or if the other headset works (or even if it doesn't actually) then I would suggest a 3.5mm to USB adapter and connect through that. It should work fine that way.
 
It is possible that the place you are connecting it is either output only, which will not work with a headset/mic as it needs an input/output to work. Or the port isn't working correctly in the laptop. Which happens a lot. I would try checking to make sure if it is output only or not first. Then, if it is both, try another headset in it to see if that works. If it turns out to be output only, or if the other headset works (or even if it doesn't actually) then I would suggest a 3.5mm to USB adapter and connect through that. It should work fine that way.
 
Dec 11, 2018
3
0
10
0


 
Dec 11, 2018
3
0
10
0
Thank you for the insight. However, I'm skeptical about the port. See, I also have a bluetooth headset and the same problem occurs. Sound is working but not the mic. So, I have a feeling that it has something to do with the laptop.
 
Alas the port being the problem is extremely common. Sad but true. Another way to confirm it would be to try using a 3.5mm to USB adapter and try running the headset via the USB port. If it works fine, then you know for certain the laptop itself isn't the issue and it is the port.
 
Thread starter Similar threads Forum Replies Date
AbeMKE Laptop Tech Support 0
TKU Laptop Tech Support 1
P Laptop Tech Support 3
R Laptop Tech Support 1
N Laptop Tech Support 4
D Laptop Tech Support 1
aforce66 Laptop Tech Support 2
V Laptop Tech Support 2
B Laptop Tech Support 1
S Laptop Tech Support 1
R Laptop Tech Support 1
C Laptop Tech Support 1
L Laptop Tech Support 2
N Laptop Tech Support 9
Y Laptop Tech Support 1
B Laptop Tech Support 1
AMDRazer Laptop Tech Support 3
T Laptop Tech Support 6
B Laptop Tech Support 4
J Laptop Tech Support 5

ASK THE COMMUNITY