M.2 wifi card installed in Half Mini PCIE slot (Atheros AR956x): Toshiba Satellite Laptop


Sep 16, 2017

I have a Toshiba laptop Satellite L50-B and it came preinstalled with a Qualcomm Atheros Wifi Card. On the device manager in Windows it shows Atheros AR956x Wireless Network Adapter with Vendor ID: 168C and Device ID: 0036. I have installed Hackintosh (MacOS Sierra) on my laptop and wanted to upgrade my wifi card as it is not compatible with Hackintosh OS.

Upon opening my laptop back case I found the wifi card to be attached to the motherboard like this:

It is a G86C0005EG10 wifi card (with BT) and it looks like a M.2 card. But the connector of the card has more pins in it and it looks like a half mini PCIE connector. It is the stock wifi card and motherboard came from the manufacturer (Toshiba). Should I upgrade to a M.2 card or to a half mini PCIE card or I can upgrade to both?

I was thinking to purchase Broadcom BCM94352HMB which is a dual band wifi card. Will it be compatible with my laptop?

Also can you tell me from the pictures does my laptop have 1x1 antenna or 2x2 antenna. It looks like a 2x2 antenna but I always used to think that my laptop have 1x1 antenna as I never got speed more than 150mbps on my laptop with my xiaomi router 3 which have 300mbps 2.4 GHz connection on 802.11n. (The router is set to 40M bandwidth and it easily connects at 300mbps with other laptops in my home)

P.S: I couldn't get much of my motherboard information even from CPU-Z. It says "Type2 - Board Vendor/Product/Version Name1" in the 'Manufacturer'/'Model'. And it says "Intel Haswell-ULT" in 'chipset' and "Intel H8x/P8x" in 'Southbridge'.



Before you start trying to change out adapters, do you need any faster speed than 150? How fast is your internet connection? If your WiFi is as fast or faster than the ISP connection, getting a faster WiFi card won't do you any good unless you move files around the internet network often.
Thread starter Similar threads Forum Replies Date
K Laptop Tech Support 3
C Laptop Tech Support 1
Pharoah742000 Laptop Tech Support 0
M Laptop Tech Support 6
JBH81194 Laptop Tech Support 2
Steven2302 Laptop Tech Support 2
Korko123 Laptop Tech Support 18
F Laptop Tech Support 4
S Laptop Tech Support 1
T Laptop Tech Support 1
SkiBaBopBaDopBop Laptop Tech Support 1
J Laptop Tech Support 5
mikmikasd Laptop Tech Support 2
B Laptop Tech Support 5
dinso Laptop Tech Support 1
pradeepsnayak Laptop Tech Support 2
K Laptop Tech Support 9
A Laptop Tech Support 2
Jovke8882 Laptop Tech Support 3
P Laptop Tech Support 0
Similar threads
Question Packard Bell stuck on Office 2010 install after system restore
Question Windows 10 clean install on my Satellite S55t-A left her missing her toshiba drivers, she’s naked! We need help?
Question HP laptop replaced power switch after breaking it during new hdd install now doesn't turn on
Question Lenovo Ideapad Creator 5 15MH05 M.2 SSD hard drive installment issue
Question My newly installed ram is fine, but my laptop restarts randomly.
Question Is it possible to install a 2TB HDD alongside the 512GB SSD that came with my laptop?
Question failed to install bios on toshiba portege R830
Question help with windows 10 install
Question error 0xc0000225 (winload.efi missing/corrupted) everytime I tried installing windows 10 through a bootable usb drive
Question If I Install Nvidia Driver, Immediatelly Get BSOD nvlddmkm.sys
How To [SOLVED] Freezing/Stucking BIOS on ASUS ROG logo after installing SSD. GL702VM & others ASUS rog laptops
Question Laptop dead after installing SSD
Solved! My laptop shuts down when I install gpu drivers
Question Toshiba Satellite A105, Win10 install problem
Solved! Acer aspire 5733 continuous long beep only on windows installation
Solved! Asus VivoBook x512 hdd installation
Solved! Help asap please.Reboot and install proper boot device. SATA not present in bios
Question Asus laptop won't turn on after ssd install
Solved! Why can't i install programs on my laptop?
Question Just installed a second HDD in my laptop, can I clone it to make it bootable if primary HDD fails (without physically moving the drive)?