MSI Ghost Pro 2QE "Killer" Wifi dead/dying

Ender P

Honorable
Jul 5, 2013
5
0
10,510
0
I recently bought an MSI Ghost Pro 2QE for part-time gaming and general laptop use. I bought it used, and everything worked fine for a day or two. Then the wifi stopped working. Only the wired ethernet connection showed. The wireless card - a "killer" card - said it was no longer installed. It's hard for me to imagine how the wireless card crawled out of the computer when I wasn't looking.

I tried uninstalling and reinstalling drivers from Killer's website - no luck. I uninstalled the killer software suite, reinstalled the drivers only version. No luck.

Then the next day I turned it on to keep trying, and it worked again. It worked for a week. Today the wireless card disappeared again. I can't adequately describe how frustrated I am at this point. This wireless card makes me want to live up to its name!

Any ideas?

Update: I updated graphics drivers, and on the next boot the internet was dead again.
 

Ender P

Honorable
Jul 5, 2013
5
0
10,510
0
I re-reinstalled the driver again, as a qualcomm atheros instead of killer. It's working now. If it drops out again I'll do that tear down and check the connections.
 
Thread starter Similar threads Forum Replies Date
X Laptop Tech Support 0
imseemlost Laptop Tech Support 3
T Laptop Tech Support 0
L Laptop Tech Support 6
K Laptop Tech Support 1
B Laptop Tech Support 1
M Laptop Tech Support 1
M Laptop Tech Support 1
P Laptop Tech Support 1
D Laptop Tech Support 4
C Laptop Tech Support 7
S Laptop Tech Support 4
T Laptop Tech Support 1
O Laptop Tech Support 1
S Laptop Tech Support 2
I Laptop Tech Support 1
M Laptop Tech Support 1
S Laptop Tech Support 1
R Laptop Tech Support 2
X Laptop Tech Support 3

ASK THE COMMUNITY