ace31220

Commendable
Jun 20, 2016
6
0
1,510
0
Hi so recently I opened up my laptop(apparently CMOS battery needed replacing) and though I did not touch it, my ribbon cable that goes to my screen burned. The laptop itself still works just the screen doesn't, I can output to another display and use it perfectly. I tried replacing the cable that burned with no luck, then the screen, still no luck, and I even tried cleaning the port where the cable goes (I used 90% iso alcohol and there seemed to be no burn marks). Im here looking for help, I'm no longer under warranty and id love to get my laptop working again, one thing to add is my WiFi card doesn't work either now (praying its not the mobo)

My laptop is a MSI ge72 2qf

Please help if you can and thank you in advanced for your time
 

ace31220

Commendable
Jun 20, 2016
6
0
1,510
0


There's no sign of damage though, nothing burned or black, all the pins (or wires) are all intact
 
Thread starter Similar threads Forum Replies Date
X Laptop Tech Support 2
ANeedyMan Laptop Tech Support 0
Jcano2605 Laptop Tech Support 0
A Laptop Tech Support 0
J Laptop Tech Support 0
Unkn0wnUs3r Laptop Tech Support 0
Nyrean Laptop Tech Support 0
Layton99 Laptop Tech Support 4
P Laptop Tech Support 0
H Laptop Tech Support 2
D Laptop Tech Support 2
B Laptop Tech Support 3
C Laptop Tech Support 4
S Laptop Tech Support 4
Kawaii Penguin Laptop Tech Support 1
R Laptop Tech Support 1
mac29 Laptop Tech Support 1
0 Laptop Tech Support 2
H Laptop Tech Support 1
H Laptop Tech Support 7

ASK THE COMMUNITY