MSI63 VR HDMI Spark now not turning on (including no charging light)

Tom_

Honorable
Mar 20, 2012
5
0
10,510
0
Hi there,

When I plugged in my MSI63VR to my tv the hdmi sparked and so did the back of my TV,

I changed to a different HDMI cable and it seemed to work fine,

The laptop continued to work and I watched about 30 minutes of Ready player One (quite enjoying so far)

The low battery sign appeared which was weird as the charger was plugged in, I checked the charger was plugged in properly, it was and the laptop had the charging icon. Then the laptop turned off a good 5 minutes later which leads me to believe it wasn’t charging since the spark.

Now the laptop won’t turn on at all, I’ve tried the battery out hold the power for 30 seconds > tried just power cable & just the battery. (Not easy btw as the GS63VR is not the most user friendly to get into (15 crews in all)

I’ll buy a new power cable tomorrow, but I don’t think it’s the charger as when the cable is plugged in i can feel a slight buzz of electric on the metal body of the laptop

It’s a refurb model from the US and I am located in Asia so not sure warranty is an option,

Thanks for any suggestions,

T

 
Thread starter Similar threads Forum Replies Date
B Laptop Tech Support 4
B Laptop Tech Support 1
G Laptop Tech Support 2
A Laptop Tech Support 1
P Laptop Tech Support 5
A Laptop Tech Support 1
C Laptop Tech Support 11
D Laptop Tech Support 1
N Laptop Tech Support 2
M Laptop Tech Support 3
S Laptop Tech Support 1
L Laptop Tech Support 2
D Laptop Tech Support 2
S Laptop Tech Support 1
L Laptop Tech Support 1
Marshall Honorof Laptop Tech Support 2
N Laptop Tech Support 3
D Laptop Tech Support 1
A Laptop Tech Support 1
A Laptop Tech Support 5

ASK THE COMMUNITY