Question MX 150 isn't working as expected. Legging games too much.

May 5, 2019
3
0
10
0
I have recently bought Asus S15 S530FN what has i7 8565 processor, 8GB ram, 256GB SSD, Nvidia MX 150 2GB. I have installed old games like NFS Hot Pursuit, Rivals, Most Wanted 2012. None of these are playing smoothly even with low graphics. In Nvidia settings I have also lower the graphics quality and made settings for high performance. But didn't help that much. A very little improvement. Any suggestions?
 
May 5, 2019
3
0
10
0
Thanks so much man. It really worked. But now rarely the game is legging although much smoother before. Could you please tell me if there is any other possible way which can improve performance? Thanks again :)
 
Apr 18, 2019
3
0
10
0
Glad to hear that. Maybe one of these will solve your problem
  • In the Nvidia setting set the power management mode to "prefer maximum performance"
  • Try turning off Vsync and lower/disable the AA
  • Right click the battery icon then open power option, open the change plan setting-> advance power setting->in the processor power management set the maximum to 99% on both battery and plugged in
Hope this helps?
 
Thread starter Similar threads Forum Replies Date
Hacknique Laptop Tech Support 0
S Laptop Tech Support 1
Cyclequeen Laptop Tech Support 2
chains65212 Laptop Tech Support 2
M Laptop Tech Support 0
mathiasjrg Laptop Tech Support 1
melihiseri Laptop Tech Support 1
gaurav1811 Laptop Tech Support 3
Mantas9971 Laptop Tech Support 8
CL19 Laptop Tech Support 1
FalKoopa Laptop Tech Support 3
A Laptop Tech Support 1
G Laptop Tech Support 5
Srijal Kc Laptop Tech Support 2
R Laptop Tech Support 3
R Laptop Tech Support 1
S Laptop Tech Support 1
B Laptop Tech Support 1
6 Laptop Tech Support 1
Boxstep Laptop Tech Support 1

Similar threads


ASK THE COMMUNITY

TRENDING THREADS