My rca galileo pro will turn on rca screen then to galileo pro screen then repeats the same 2 screens over and over again help

shanasti.owens.04

Prominent
Jan 8, 2018
1
0
510
0
Help fix rca galileo pro it will come on to the rca screen then the galileo pro screen was working the night before help me please thanks 4 your time
 
Try starting it up in "Safe Mode" and see if it will stop rebooting. If it does, while you will have limited access in that mode, it will also tell you there is something on the device that is the cause. Bad app, virus, malware, etc. You would have to then remove the problem and restart the tablet to get it working normally again.

If, however, it still does this and won't work correctly even in "Safe Mode", then you may have a hardware issue.

To get into "Safe Mode" please do the following.

1. First turn off the tablet.

2. Next press and hold "Power" until you see the manufacturers logo on the screen, then release the power button.

3. "Quickly" press "Volume Down" and hold it for few seconds until you see the message "Safe mode: ON" or something similar.

4. If you wanted disable it, simply repeat the steps above, and you should see "Safe Mode: OFF" rather than on.
 
Try starting it up in "Safe Mode" and see if it will stop rebooting. If it does, while you will have limited access in that mode, it will also tell you there is something on the device that is the cause. Bad app, virus, malware, etc. You would have to then remove the problem and restart the tablet to get it working normally again.

If, however, it still does this and won't work correctly even in "Safe Mode", then you may have a hardware issue.

To get into "Safe Mode" please do the following.

1. First turn off the tablet.

2. Next press and hold "Power" until you see the manufacturers logo on the screen, then release the power button.

3. "Quickly" press "Volume Down" and hold it for few seconds until you see the message "Safe mode: ON" or something similar.

4. If you wanted disable it, simply repeat the steps above, and you should see "Safe Mode: OFF" rather than on.
 
Thread starter Similar threads Forum Replies Date
T Android Tablets 0
R Android Tablets 1
Harlie Android Tablets 3
N Android Tablets 2
S Android Tablets 1
I Android Tablets 1
R Android Tablets 1
S Android Tablets 1
Z Android Tablets 1
N Android Tablets 1
L Android Tablets 1
D Android Tablets 1
M Android Tablets 1
M Android Tablets 1
X Android Tablets 5
S Android Tablets 1
D Android Tablets 1
P Android Tablets 2
B Android Tablets 2
B Android Tablets 1

ASK THE COMMUNITY