NEW Hard Drive

Mar 27, 2018
2
0
10
0
OK, so I have a Dell Latitude. It came with Windows 10 and a 500GB Toshiba HDD. I recently purchased a Seagate Barracuda 1TB HDD.

Problem. When I put the new HDD into the laptop it's not recognized. BIOS doesn't see it, when I try to do a clean install the installer says I need to load the drivers. I tried loading the drivers, nothing. I tried to load with System Image Recovery and its still asking for drivers. the drivers that i found aren't helping.

When I attach the new HDD via USB it's recognized, and I even went as far as to clone my original HDD onto the new drive and I'm still running into the same problem.

This shouldn't be this hard. What am I doing wrong? HELP!!!!
 
And you're sure it's fully seated/properly connected? (We've had laptops come in for this same issue and, several times, it turned out the drive was situated under the port, not in it.) If you don't feel or hear it spinning, it means it's not getting power.
 
Thread starter Similar threads Forum Replies Date
OhGod Laptop Tech Support 0
J Laptop Tech Support 0
Mvnch Laptop Tech Support 0
OhGod Laptop Tech Support 0
A Laptop Tech Support 0
M Laptop Tech Support 0
I Laptop Tech Support 0
G Laptop Tech Support 1
M Laptop Tech Support 13
A Laptop Tech Support 0
M Laptop Tech Support 0
G Laptop Tech Support 0
E Laptop Tech Support 0
C Laptop Tech Support 7
Thor-azine Laptop Tech Support 2
OhGod Laptop Tech Support 25
F Laptop Tech Support 0
AntmanMcLean Laptop Tech Support 1
lucasblack29 Laptop Tech Support 1
R Laptop Tech Support 1

ASK THE COMMUNITY

TRENDING THREADS