New Lenovo y510p powers off/crashes when gaming; SLI/AA the blame??

KGB ate my bread

Estimable
Feb 28, 2014
2
0
4,510
0
Well, I just got this laptop less than a week ago. The main things I've done with it since has been to update the GeForce drivers, install steam/origin, install office, and install some other programs on here that I use regularly on my desktop.


I've noticed that in some games, the laptop just shuts down completely. No warning, no errors, just fade to black and turn off. I've noticed that when this happens that the system isn't running hot nor am I seeing an overheating warning. The games that have crashed thus far are the only games I've tried running on here:
Dawn of War II during the performance test (crashed until I disabled SLI), Team Fortress 2 (crashed when SLI was enabled, then managed to play a round on a server after Anti-Aliasing was disabled), and Battlefield 3 (Crashed when run on SLI, haven't attempted to run again with SLI disabled).

Is this a common problem for SLI systems? The cards are both GT 755Ms. I know some games require SLI profiles to run, but I would think that this would exist for games like Battlefield 3 and not create a huge problem where the system shuts off.

Any thoughts/ideas? I'll try this on another socket shortly (in a lab and there's always the off chance that there could be something wrong with the socket/wiring here), but I just can't imagine that being the issue since it seems like tinkering with SLI and AA settings seems to get things working for me. The only other thing I can think of would be something like McAfee just being an awful piece of software (pre-loaded on laptop) since AV programs can cause funky issues.


 

KGB ate my bread

Estimable
Feb 28, 2014
2
0
4,510
0
Welp, a thing I failed to mention is that I was running the laptop without the battery in it since I didn't feel that it was necessary and kinda want this battery to last as long as I can get it to last.

Well, tried BF3 again with the battery in and instead of crashing, I get this lovely error now..



which I guess I need to do some research on.
 
Thread starter Similar threads Forum Replies Date
T Laptop Tech Support 1
S Laptop Tech Support 1
H Laptop Tech Support 4
K Laptop Tech Support 1
I Laptop Tech Support 8
P Laptop Tech Support 1
M Laptop Tech Support 1
T Laptop Tech Support 1
K Laptop Tech Support 11
D Laptop Tech Support 3
R Laptop Tech Support 1
C Laptop Tech Support 3
P Laptop Tech Support 2
J Laptop Tech Support 1
T Laptop Tech Support 3
M Laptop Tech Support 1
P Laptop Tech Support 1
H Laptop Tech Support 2
B Laptop Tech Support 1
W Laptop Tech Support 1

ASK THE COMMUNITY