Question No Audio on my Dell XPS

Sep 29, 2019
3
0
10
0
Hello,

I have an old laptop Dell XPS 14 that I bought in 2012. It has windows 7 professional 64 bit on it. A few days ago the audio stopped working altogether. There was a red cross on the speaker icon on the bottom right of the screen. It said "no audio device installed".

Audio troubleshooting could not fix the problem. In device manager, I tried updating the drivers of the audio devices shown (one was I believe Intel High Definition Audio and the other was NVIDIA Virtual Audio WDM) but windows said their drivers were up to date. I even disabled and re-enebled them. Nothing. So then I deleted both and rebooted to let windows find them and re-install their drivers from scratch. The system reinstalled only the Intel one. Still no audio.

I have had this same problem a year ago. Popped out from nowhere, not even after a windows update (that I am aware of). After trying multiple things, the only thing that worked was to use System Restore. It did work. Which is why I believe the problem is a software one. The problem is that, this time, I did not have the time to work on the issue right when it showed up, and when I got to it 2 days later, the only system restore option I had was from a few hours earlier, well after the problem had shown up. I was puzzled. I guess this could be because I was using 98% of my hd space and the other system restore options had been deleted (?) but cannot be sure. I tried using that restore option anyway, but the audio problem persisted. I also tried a number of things I found in other forums to find other possible system restore points, but there were none.

After I browsed several forums to see if there was something I had not tried, I gave up to the only possible solution: reinstalling windows 7. Alas, I did it. With backup and all, it took me a whole day. But the audio is still not working :eek:

Now when I hover on the speaker icon it says "no speaker or headphones are plugged in". Which is different from yestterday. In Device Manager, it shows High Definition Audio Device as the only audio controller. Driver is up to date, according to windows. If I go to Contro Panel>Sound>Playback I see two identical devices Digital Audio (HDMI) "not plugged in". I tried disabling one, or both, or re-enabling them, but nothing. Still no audio. It is crazy that it was working perfectly just 2-3 days ago.

So now I am somewhat lost. If not even reinstalling windows works, what can I possibly try? Thanks in advance for your help.

Simon
 
Last edited:
Sep 29, 2019
3
0
10
0
I decided to download video and audio drivers from dell.com specifically for my laptop. Installed them all. Now in Device Manager what I see is Intel(R) Display Audio. But the audio is still not working...
 
Sounds like you have tried checking all possible 'software' issues, but it may not be software. It could easily be a hardware problem. Well except one, I didn't see listed. Did you try installing an older driver, rather than the most recent one?

If that last option doesn't do it (which to be honest if you reinstalled the whole OS it should have installed older drivers) then it sounds like you have a hardware problem. Especially if the system isn't even recognizing the hardware.

I would suggest taking it and having a tech look at it.
 
Sep 29, 2019
3
0
10
0
Thank you for your reply. Unfortunately it did not work.

So I had given up on the problem and then, long story short, now it works. Earlier today my wife accidentally unplugged my laptop while it was on. Since my battery is dead, the laptop shut down. When I turned it back on, I had to do the usual drill: press F1, then log in... when I logged in, I heard a weird noise, like when you blow on a mike, and the audio was back. I could not believe it. Now it works.

Now in device manager I see three devices, not one: in addition to the Intel Display Audio, there is NVIDIA Virtual Audio Device (WDM) and Realtek Hih Definition Audio. How they got there, well, I am not sure.

I am not sure how helpful this can be for others who may have the same problem, but well, it looks like it was indeed a software issue.
 
Thread starter Similar threads Forum Replies Date
sadqt Laptop Tech Support 1
S Laptop Tech Support 3
C Laptop Tech Support 0
R Laptop Tech Support 8
J Laptop Tech Support 2
M Laptop Tech Support 7
king-slim Laptop Tech Support 4
K Laptop Tech Support 1
M Laptop Tech Support 0
B Laptop Tech Support 1
L Laptop Tech Support 5
mathiasjrg Laptop Tech Support 1
C Laptop Tech Support 1
L Laptop Tech Support 1
P Laptop Tech Support 2
Sebastrole Laptop Tech Support 4
Bhuvnesh011995 Laptop Tech Support 2
davidsonc91103 Laptop Tech Support 1
S Laptop Tech Support 15
P Laptop Tech Support 1

ASK THE COMMUNITY