No mic input but audio output is fine.

TzHaar

Estimable
Nov 12, 2015
2
0
4,510
0
Just built a new desktop and keyboard and everything is working fine except for when I plug in my headset, the audio plays but my mic doesn't pic up any sound. The keyboard is a Razer Blackwidow Stealth and it has 2 jacks, 1 for mic and the other for headset, but my headset, Turtle Beach XO7, only has 1 cord that I plug into the headset jack. I have tried with my other headset which is just a pair of Beats earbuds but with the same issue being present.

Edit: I've tried updating drivers, updating windows, checking sound settings, etc. but no luck. Going to borrow someone's USB headset next to test if its just the jacks.
 

Darkseiders

Estimable
Oct 23, 2015
9
0
4,520
2
The problem is that you can't plug a headset like that into just the headphone jack in order to use the mic. You need a splitter to plug into the mic and headphone jacks. That isn't a Headset jack, it's a Headphone jack.
 

TzHaar

Estimable
Nov 12, 2015
2
0
4,510
0
So I need a female to 2 male splitter. Thank you for the response, didn't know those existed as I've only seen male to 2 female but after checking walmart they do have them so I'll go pick a pair up!
 
Thread starter Similar threads Forum Replies Date
C Audio 3
T Audio 0
C Audio 1
T Audio 2
J Audio 7
P Audio 1
J Audio 2
V Audio 4
P Audio 1
C Audio 4
W Audio 1
B Audio 4
R Audio 10
J Audio 7
S Audio 6
K Audio 12
S Audio 2
W Audio 7
M Audio 7
M Audio 1

ASK THE COMMUNITY