Nvidia Optimus and black screen in some apps

vorob

Distinguished
Jan 10, 2008
1
0
18,510
0
Hello everyone. I’ve got a problem with my laptop which can be easily described as: “Some applications won’t work on my discrete videocard, showing black screen”. And I even know a solution: “Reinstall your Windows”. But still, before I’ll do this, I wanna try understanding what caused my issue.

So, I’ve got a laptop: Lenovo ideapad Y580

Code:
Intel Core i7-3610QM (2.3Ghz/3.3Ghz) (http://goo.gl/JqP3E7)
Nvidia Optimus:
- Intel HD 4000 (http://goo.gl/swtRgP)
- Nvidia GeForce 660m (http://goo.gl/4H21OM)
8Gb DDR3-1600 / PC3-12800 (2х HMT351S6CFR8C-PB)
Windows 10 x64 Technical Preview Build 14390
Intel driver - 10.18.10.4425
Nvidia driver - 353.62
A few month ago I faced a problem, my Adobe Lightroom started looking like this:
https://pp.vk.me/c633827/v633827184/395b5/YMXWs6ChP6s.jpg

Lightroom is using my 660m to accelerate its performance. If lunched w/o acceleration or on Intel 4000, all is ok, but on 660m I’m getting black screen.

Same problem with recent System Shock demo. On 660m I’m getting black screen, while I hear sound and can press buttons.

And same thing in latest 3dmark:
https://pp.vk.me/c633827/v633827184/395ab/pI0i2wCKRHI.jpg

Just black screen and possibility to press buttons.

But other games and applications work just fine on 660m. Even Lightroom worked perfectly earlier this year.
I just don’t know what has changed in my computer, so i started getting such problems.

Things I’ve tried:
Delete Nvidia driver and install one from windows updated
Install latest Nvidia driver from official site with clean setup
Change build of Windows (its easy since I’m sitting in TH program)
Update Intel driver

Nothing of this helped…
Any advice?

 

GeRgY

Admirable
Moderator
Jan 17, 2015
590
0
6,410
221
Hello,

I will give you some advices:
1) reinstall drivers (download latest drivers from nvidia!) - saw that you did it but... do it one more time
2) open your power settings and uncheck the power save mode on your GPU. -> power management mode - prefer MAXIMUM
2.1) your power mode should be on high performance ... right?
 

GeRgY

Admirable
Moderator
Jan 17, 2015
590
0
6,410
221
Hello,

I will give you some advices:
1) reinstall drivers (download latest drivers from nvidia!) - saw that you did it but... do it one more time
2) open your power settings and uncheck the power save mode on your GPU. -> power management mode - prefer MAXIMUM
2.1) your power mode should be on high performance ... right?
 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 1
adudewicz1 Laptop Tech Support 3
T Laptop Tech Support 2
M Laptop Tech Support 2
G Laptop Tech Support 5
MySeaGateIsDown Laptop Tech Support 2
F Laptop Tech Support 2
S Laptop Tech Support 1
S Laptop Tech Support 1
K Laptop Tech Support 1
F Laptop Tech Support 1
S Laptop Tech Support 2
K Laptop Tech Support 1
L Laptop Tech Support 5
J Laptop Tech Support 1
G Laptop Tech Support 9
J Laptop Tech Support 3
L Laptop Tech Support 2
K Laptop Tech Support 1
R Laptop Tech Support 5

ASK THE COMMUNITY