Onkyo Subwoofer buzzing/weird noise ONLY when playing Games (PC)

Skretting91

Commendable
Sep 11, 2016
2
0
1,510
0
Hi, so i recently got this 5.1 surround from my brother.

I connected it to my computer. 1 Hdmi from my computer to the onkyo receiver, and 1 from the receiver to my television.
When i started it all up i noticed something strange.
In order for the subwoofer to be ON at all, to even work i had to put my receiver mode to "Theater dimensional". Or else the subwoofer wouldnt be on.

But whenever i start up a game on my pc this buzzing sound starts coming from my subwoofer?
Ive tried different games and it happens on all of them. And it seems like the buzzing noise changes depending on what i do within the game itself. (moving charackter around etc)

I can solve this by turning off the theater dimensional setting > Direct mode
But then i get sound without a subwoofer and it sounds horrible.

Any idea what this might be?

Any help will be appreciated
 
You can get the manual online which should help. Here is a link to it in English
http://www.onkyousa.com/Downloads/manuals.php?source=globalnav
If the sub is passive you can't connect it to the line level RCA subwoofer out on the receiver. If you have it connected to the speaker terminals then you have to set up the receiver as if you had large front speakers and no subwoofer. The bass will go the the L-R fronts and the sub connected to those terminals. If you set the receiver to sub yes it will send the bass to the subwoofer out RCA jacks that you are not using.
 
Did you do the full set up on the Onkyo? If you don't have the manual download it. Check the settings. Some receivers have a setting so that the sub works all the time.
If the subwoofer has a three prong power cord a 3 to 2 adapter may help the noise problem. If not then try it on the AC cord of the receiver.
 

Skretting91

Commendable
Sep 11, 2016
2
0
1,510
0
I honestly have little too no idea what im going. I just went to the store and bought this cable that this guy said i needed to get sound on my computer with the receiver etc...

Ive tried Going through all the settings on the receiver itself and the only time i get any subwoofer action going on is when i put it in theater dimensional mode.

As for the power cord it goes inside the receiver itself and attaches with 1 blue and 1 white colored cable at the end (coming out of the main cable thing)
The receiver i have is an Onkyo HT370

The subwoofer doesnt have any powercord, it juts 1 cable with 2 cables coming out of it into the receiver.

Apoligize for my rusty english, but you get the point.

Im completely new to this. Appreciate the help tho
 
You can get the manual online which should help. Here is a link to it in English
http://www.onkyousa.com/Downloads/manuals.php?source=globalnav
If the sub is passive you can't connect it to the line level RCA subwoofer out on the receiver. If you have it connected to the speaker terminals then you have to set up the receiver as if you had large front speakers and no subwoofer. The bass will go the the L-R fronts and the sub connected to those terminals. If you set the receiver to sub yes it will send the bass to the subwoofer out RCA jacks that you are not using.
 
Thread starter Similar threads Forum Replies Date
diesel888 Audio 1
M Audio 1
P Audio 4
hostos Audio 2
V Audio 1
G Audio 1
J Audio 5
xkratosx Audio 5
M Audio 1
B Audio 4
D Audio 1
N Audio 1
J Audio 2
D Audio 1
W Audio 1
A Audio 3
S Audio 10
D Audio 1
L Audio 1
D Audio 3

ASK THE COMMUNITY