Photoshop CS6 (Win7x64) - Keyboard Shortcuts Stop Working

Status
Not open for further replies.

THRobinson

Distinguished
May 17, 2009
54
0
18,590
3
Seen a lot of people asking about this on the Adobe forums, even asked a few times myself, but... horrible forums. Most times I never get a reply at all, or I get an 'Adobe Expert' who says run an update and that's it.

Basically, running Photoshop CS6 x64 for a year no issues. Have in that time formatted my computer 3x (not due to issues, just boredom and cleaning up the machine). 2 weeks ago I formatted my system and installed everything as usual, then started to notice a problem in Photoshop.

I'll be working just fine, then the shortcuts stop working... like using the [ ] brackets for brush size, or CTRL+0 to resize the image on screen. Sometimes closing the file and reopening fixes it, but 90% of the time I have to close Photoshop totally and reopen to fix the problem.

Unlikely a keyboard issue since keys work in other programs, and it's not like I have to unplug the keyboard and plug it back to get it to work.

Small, but VERY annoying issue. I've reset my preferences, I don't have a custom workspace, and I have tried disabling the mini-bridge tab at the bottom as per a thread I read. Again, seen many threads, no real solutions.

And yes, updates have been run, been using this version for at least 6 months so, should be fine.

Anyone ever had this issue?
 

THRobinson

Distinguished
May 17, 2009
54
0
18,590
3
Well, did a buttload of photos the past 2 days and not 1 single issue so, seems to have been the issue.

So

- Go to Control Panel->Region and Language->Keyboards and Languages->Change Keyboards
- In the General tab, under 'Installed Services', make sure there is only 1 item under keyboard, if you're English, just stick with the default US because the Canadian one might show up as Multilingual.

...on a side note, why can't you pick your own responses as an answer? :)
 

kenrivers

Splendid
Moderator
I see what you mean about the Adobe forums. I have seen possible solutions ranging from resetting the tools presets to their default settings to the possibility another running app being the source of the problem (such as a browser extension). The top suggestion, as you noted, was to make sure you had installed the latest updates. I hope someone who knows the solution will post and be able to help you out.
 

THRobinson

Distinguished
May 17, 2009
54
0
18,590
3
Ya... I posted and all I got was 'run an update'.. which is such a BS solution given that I stated in my post that I've been running CS6 since last year without issues, and, that I also mentioned that I've seen posts ranging back to CS4 about the same problem. But... that's Adobe... I think most people on that site post a response just to see how many posts they can make in a year. I've yet to see someone post a cut/dry solution to someone's problem.

Well... likely I'll dig a keyboard out and swap with it... just on the off-chance that's the issue. Kinda hoping it is since I want a new one anyways. :D

Otherwise, I just did a full backup 2 weeks ago, so, might simply copy a few files to my external drive, and format the C:\ and install Win7x64 and CS6 only for a few days, see if still an issue. If it is, then I'm assuming it's definitely an Adobe issue.
 

kenrivers

Splendid
Moderator


Right you are, after reading some of the posts I gathered this is not a new issue with Photoshop. I agree, it would be nice if there were a cut and dry solution. Let me know if a new keyboard solves the problem. This got me to thinking I need to test the keyboard shortcuts with Photoshop as well (running the same version as you).
 

THRobinson

Distinguished
May 17, 2009
54
0
18,590
3
Main problem for me is changing brush sizes with the [ and ] keys, and using the CTRL 0,-,+ keys for zooming in/out.

Odd thing is that it's random when it happens, and last time it happened I noticed that I could use the left CTRL and zoom in/out, but using the right CTRL key did nothing. But like I said, switching to something like Notepad and just doing some copy/paste showed that the right CTRL wasn't sticking or anything.

Just reinstalled everything about 2 weeks ago, and Photoshop is totally default with exception of adding Actions to the right side for quick access. Been updating poster art for TMDB (the Movie Database) so just been cropping artwork, maybe running a sharp filter, flatten and save... VERY basic stuff which is why I'm not sure the problem started. Usually I'm editing photos and have 20 layers on the go... crop/flatten/change to sRGB and save... shouldn't be an issue.

But will try another keyboard, different USB slot just in case... last reinstall I cleaned up my cables a bit so, maybe stuck the keyboard into a flakey USB port? Otherwise, only change in the system was I upgraded my CPU from an E6600 Core2Duo, to a Q9450 Core2Quad, and switched my ATI HD5670 with an nVidia GTX650 Ti. Worked fine for the week before I formatted the C:\.

Maybe Adobe dislikes GeForce?
 

kenrivers

Splendid
Moderator
I doubt the GeForce card is the problem. I use a GeForce GTX580 and have had no problems with keyboard shortcuts in Premiere Pro but have yet to experiment much with keyboard shortcuts in Photoshop. Don't know about the USB keyboard as I use an older keyboard with a PS/2 connection. I tried a USB keyboard and was less than thrilled with it so I switched back to the older one with the PS/2 connection. I remember now why I switched, I was having trouble with a Windows install using the USB keyboard so I switched. I am getting better with Photoshop as I have a part-time job as a graphics artist (learning as I go) and must say I have found the beauty of using layers. Until recently I mainly used it to edit/create custom DVD menus. That is how I learned the value of layers.
 

THRobinson

Distinguished
May 17, 2009
54
0
18,590
3
I have a 10yr old MAC keyboard that works, USB, but a few keys unless you hit dead centre straight down, they stuck... got this illuminated one on sale, but, Maxell does not make a good keyboard. Less than a year and stuff feels lose, letters wearing off, etc... should have gone with the Logitech illuminated keyboard, but $30 vs $100 at the time. Still annoyed, when you compare under a year, to 10yrs for the Apple keyboard. Pays to pay more I guess. :D

I went to school for design... between jobs right now though and finding that I enjoy photography more, so been using InDesign/Illustrator way way less, and Photoshop way way more... so not sure if the problem exists anywhere else in the CS6 suite, or just Photoshop.

Layers, are amazing. I remember way way back before I went back to school for Design (went back when I was 31).... using Photoshop I didn't understand what the big deal was all about and switched back to PaintShop pro. Once I learned about layers, I switched back really fast. :D
 

kenrivers

Splendid
Moderator
I'm using an old HP keyboard from a computer that is long gone but the keyboard has stood the test of time. My educational background is Psychology/Business but I got into videography while teaching computer classes and started using Photoshop while working on entries for the state fair web & graphic design competitions.
 

THRobinson

Distinguished
May 17, 2009
54
0
18,590
3
May have found a solution...

I remember back in WinXP I (and a friend of mine later on) had an issue where outta no where the keyboard would go wonky, stuff like one of the keys would show an upside down question mark, stuff like that.

I figured it out... we're Canadian so when setting up the system for keyboard we pick Canadian (Eng). WinXP would then install both Canadian (Eng) and Canadian (French). I think the system would sometimes get confused, or switch profiles, or something but deleting the extra profile fixed the problem. So as a habit, after every install I always deleted it when I went to hide the language bar.

So, on a whim I checked it out... I use to install using Win7, I now have a Win7SP1 disc so may be what changed... but... now installed showing the Canadian Eng, as Canadian Multilingual... as well as the default USA since it's what was used I guess during the install. I figured maybe with all the crazy Photoshop shortcut key combos, maybe it was switching languages or something.

Anyways, US and CAN keyboards are the same so, deleted all keyboards except the default US... and so far so good. I haven't used photoshop as much the past week, but, when I was having issues, they would occur within 5min of use. I used it for 2h after trying this solution and no problems.

I'll keep an eye on it for the next week or two... then post if still fixed or not. If fixed, I'll post on the Adobe site as maybe the first actual solution. :D
 

THRobinson

Distinguished
May 17, 2009
54
0
18,590
3
Well, did a buttload of photos the past 2 days and not 1 single issue so, seems to have been the issue.

So

- Go to Control Panel->Region and Language->Keyboards and Languages->Change Keyboards
- In the General tab, under 'Installed Services', make sure there is only 1 item under keyboard, if you're English, just stick with the default US because the Canadian one might show up as Multilingual.

...on a side note, why can't you pick your own responses as an answer? :)
 

THRobinson

Distinguished
May 17, 2009
54
0
18,590
3
10 days later and still not a sign of the problem... hopefully this fixes the issue for others.

EDIT - Been 2 months. Still no issues. Seems to be the fix in my case. I'm glad I figured it out, but still annoyed at how useless Adobe was with the issue.
 

Dotted_Line

Estimable
Feb 10, 2014
1
0
4,510
0



I have a potential solution for you if this hasn't been solved yet :p As I had the same problems that kept going on and off.
I went into Edit > Keyboard Shortcuts to try to rebind my shortcut keys. Needless to say I found out that my computer had automatically switched my keyboard to "Canada French" which switches the whole keyboard configuration around (changing my "[" to "^") . Anyway, even if this is not your issue, just try rebinding!

 

THRobinson

Distinguished
May 17, 2009
54
0
18,590
3
Ya, that's what my problem was. I solved it by deleting the french keyboard from my list... as seen in my post marked as being the solution. :D

Thanks anyways. :)
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
Jennifer_Fennell Apps General Discussion 3
B Apps General Discussion 1
G Apps General Discussion 2
phix95 Apps General Discussion 16
G Apps General Discussion 0
A Apps General Discussion 3
TWTgames Apps General Discussion 1
IvakaS Apps General Discussion 3
Lumpus Apps General Discussion 4
D Apps General Discussion 4
noyaus Apps General Discussion 5
R Apps General Discussion 1
G Apps General Discussion 0
U Apps General Discussion 4
G Apps General Discussion 0
S Apps General Discussion 2
L Apps General Discussion 1
E Apps General Discussion 1
J Apps General Discussion 1
B Apps General Discussion 3

ASK THE COMMUNITY