Premiere Pro unresponsive when using external monitor.

dumpling469

Prominent
Nov 30, 2017
4
0
510
0
Hey guys, Premiere Pro seems to lag significantly and ends up becoming unresponsive when I use an external monitor plugged into my laptop for editing videos. Does anyone know what may be causing the sudden lag and unresponsiveness? I'm using a Lenovo ThinkPad P51 with a Xeon processor with integrated graphics, a Quadro M2200 gpu, 40 gigs of ram, monitor connected via displayport. Running Premiere on my laptop screen is totally fine but the moment I connect it to my monitor it just lags and stops responding. Hope someone can help!!
 
On most laptops the integrated GPU is what is used for the external connections, unless it is through HDMI and then that may well use any secondary one.

Here's the steps on how to set it to default.

1. Open the "Control Center".
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
4. Now select "preferred graphics processor" in the drop down list.

Once it is running on the right one, test the system again and see if the problem persists.
 

dumpling469

Prominent
Nov 30, 2017
4
0
510
0


Yes, the drivers should be all up to date as well as all the software. Still haven't figured out why this is happening.
 

dumpling469

Prominent
Nov 30, 2017
4
0
510
0


I am pretty sure it should be running on the same gpu. Is there a way I can check for sure? I changed the NVIDIA 3D settings so that it is using the integrated gpu, but that has not solved it one bit.
 
On most laptops the integrated GPU is what is used for the external connections, unless it is through HDMI and then that may well use any secondary one.

Here's the steps on how to set it to default.

1. Open the "Control Center".
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
4. Now select "preferred graphics processor" in the drop down list.

Once it is running on the right one, test the system again and see if the problem persists.
 

dumpling469

Prominent
Nov 30, 2017
4
0
510
0


This seems to be working great as of now - thank you very much!!
 
Thread starter Similar threads Forum Replies Date
D Laptop Tech Support 0
jondajaba Laptop Tech Support 3
R Laptop Tech Support 1
Hirinator Laptop Tech Support 1
K Laptop Tech Support 1
C Laptop Tech Support 1
A Laptop Tech Support 2
S Laptop Tech Support 2
B Laptop Tech Support 9
E Laptop Tech Support 2
N Laptop Tech Support 10
C Laptop Tech Support 1
J Laptop Tech Support 2
R Laptop Tech Support 3
VooDooVince Laptop Tech Support 1
D Laptop Tech Support 1
M Laptop Tech Support 15
L Laptop Tech Support 3
I Laptop Tech Support 1
mjohnson24 Laptop Tech Support 1

ASK THE COMMUNITY

TRENDING THREADS