problem with lenovo y50 - 70 audio jack

Linas_

Commendable
Nov 27, 2016
4
0
1,520
1
Hello,
so I got Lenovo y50 70 that has headphone/microphone combo jack and whenever I try to plug in my headphones with combined jack the sound becomes really bad unless I not fully plug them. I guess that has to do something with my laptop not supporting 4 pole 3.5mm jack because if I plug 3 pole 3.5mm headphones audio is just flawless but then if I understand correctly there shouldnt be a combo jack in my laptop if it shouldnt support it. I have tried to reinstall audio drivers without any success. ( Headphones that I am using - steelseries siberia 200, the sound is working fine on the other laptop so I suppose the problem isnt with it. )
 

hang-the-9

Titan
Moderator
I have seen this issue on some connections, I go a few headphones splitters that did the same thing. If the headphones work fine on another laptop, contact Lenovo and check with their support, it could easily be an issue with the jack.
 

hang-the-9

Titan
Moderator
I have seen this issue on some connections, I go a few headphones splitters that did the same thing. If the headphones work fine on another laptop, contact Lenovo and check with their support, it could easily be an issue with the jack.
 
Thread starter Similar threads Forum Replies Date
Q Audio 1
H Audio 0
R Audio 2
J Audio 2
G Audio 0
S Audio 3
2 Audio 3
jdip13 Audio 1
IntrepidBongos Audio 0
G Audio 1
J Audio 0
196138105 Audio 2
I Audio 6
aiden_crawford Audio 1
GenericName987 Audio 1
shdwfreecss Audio 0
T Audio 1
S Audio 1
D Audio 3
N Audio 1

ASK THE COMMUNITY