Razer Tiamat 7.1 surround sound.

LuxyBoo

Estimable
May 5, 2014
8
0
4,510
0
I know there are quite a few threads on this but I'm starting this one because all of the solutions on the others don't work.
I have the Razer Tiamat 7.1 and the surround sound mode sounds extremely flat, tinny and empty. Thing is, the sub does work in the mode because when I move the knob I can hear the difference, like I'm increasing and decrease the bass but the whole audio will still always sound flat.
I've disabled Full-Range Speakers, and enabled Bass Boost, and I've messed around and tried a few different combinations but it will never sound even as remotely good as when I turn it to Stereo mode. I have the Realtek HD Audio Managers and drivers, and my built-in soundcard on my ASRock 970 Extreme3 motherboard is the 7.1 HD audio capable Realtek ALC892.
I have all the audio cables plugged in correctly, and the subwoofer does work, but the problem that I can't remove is the complete empty and flat audio when I have 7.1 enabled.

I bought this headset for it's use of true-surround 7.1 audio, and I didn't spend $160 on it to sound worse than my impossible-to-fix G930. So please help, thanks.

Other specs: Windows 7 64 bit, AMD FX 6350, GTX 670, 16gb RAM, DirectX 11
 

MarkW

Distinguished
Dec 7, 2009
196
0
18,710
26
Tons of us waited with baited breath for the Tiamat to come out. It was a long, long wait...

And in the end, we were greatly disappointed. So much for what we thought would be a great headset.

Someday, someone will figure out how to do this right. It may need for a new technology to be invented. Or maybe just a way to use an already existing technology in a new way, but so far, every 7.1 headset I have tried has been a big, big disappointment.
 

LuxyBoo

Estimable
May 5, 2014
8
0
4,510
0


So you're saying that nobody has ever fixed it if those other options don't work for you? Damn.
 

WEKKI_

Estimable
Jan 10, 2016
1
0
4,510
0


Well most likely onboard soundcard doesnt have amp which is the reason.... Buy Asus Xonar Phoebus Solo 7.1 soundcard use it with blue low amp. And setup Flexbass from audio card settings to get better sound. Also remember set stereo mode 7.1 in audio card settings.
 

ASK THE COMMUNITY