Replaced Lenovo Screen. Starts up with logo then blank screen.

May 15, 2018
2
0
10
0
Hi!

I recently replaced my Lenovo Y50-70 laptop screen and the installation went smoothly. The only problem is that for some reason it does not want to turn on! I booted up the PC and the LENOVO logo appears on the new display as expected, but then it just stayed black. I'm currently hooked into a tv monitor through my HDMI cable. I tried changing the monitor options to "duplicate" but that doesn't work either.

The fact that I saw the Lenovo logo and that the display function works through an external montior, leads me to believe it is software related? Could I have gotten the wrong type of display?

Any help would be appreciated!
 
Try these...


Option 1 ...

1. First, while the computer is off, connect an external monitor.
2. Next turn on the computer and allow it to fully load.
3. Once loaded, press the "Windows Key" + "P" to open the "Easy Display Switcher".
4. In here select "Computer only".
5. Now shut down the computer and disconnect the external monitor.
5. Disconnect the external monitor
6. And finally restart the computer.


Option 2 ...

Make sure you wait until the computer would be fully loaded before trying this, and not try it right away like you would to say get into BIOS. This needs you to actually be where you would be when Windows Explorer loads.

1. Press "Shift" repeatedly until the "sticky keys" window shows up.

2. Now click the the link there that will lead to the "Ease of Access Center".

3. Next click "Cancel" on the the bottom right corner of the "Set Up Sticky Keys" window.

4. From here you want to click "Control Panel" on the upper left corner (it should be right beside the "Make Your Computer Easier to Use" title.

5. Locate the "Computer Settings" menu and then choose the "Recovery" icon (make sure that your view of this is by either large or small icons for easier access).

6. Now click and open "System Restore".

7. Here you want to click next on the bottom right corner (a few times) until the button "Finish" shows up and then click it. (Just follow everything prompt that the window says which will lead you to recovering your previous system, in a certain time.

8. The computer will now do the work it needs to and then reboot.


If that doesn't work, you can try the following...

You can also try doing the Ctrl+Alt+Delete and see if you can get "Task Manager" to show.


If the "Task Manager" windows shows, then choose "New Task" and then type in EXPLORER. If the desktop shows up then you need to go into "Start", "Programs", then "Accessories" and finally "Command Prompt". (Or you can do a search for CMD.)

Make sure you load the "Command Prompt" with Administrator access. Then when it loads type in....

SFC /SCANNOW

It will do a file check.

To learn more about "SFC" visit this link at Microsoft... https://support.microsoft.com/en-us/kb/929833
 
May 15, 2018
2
0
10
0
Thanks for the replies...I gave my computer another forced reboot and the problem solved itself..somehow this worked but I'm not sure why.

I'll refer to the above if I have this issue in the future. Thanks!
 
Thread starter Similar threads Forum Replies Date
B Laptop Tech Support 0
T Laptop Tech Support 1
C Laptop Tech Support 4
S Laptop Tech Support 1
R Laptop Tech Support 6
N Laptop Tech Support 6
H Laptop Tech Support 4
R Laptop Tech Support 1
L Laptop Tech Support 3
J Laptop Tech Support 3
A Laptop Tech Support 1
C Laptop Tech Support 5
V Laptop Tech Support 3
sabrix Laptop Tech Support 3
G Laptop Tech Support 3
F Laptop Tech Support 2
D Laptop Tech Support 1
N Laptop Tech Support 1
A Laptop Tech Support 1
G Laptop Tech Support 2

ASK THE COMMUNITY