SB X-FI Xtreme Gamer Sound Card

Navy_CD

Distinguished
Feb 15, 2010
3
0
18,510
0
I have installed the sound card and updated it's drivers. Except I'm haveing some really bad issues with this card. The only sound that I can get out of the card is like a 1920's radio. I need HELP configuring this card from someone. Please!!!

Thank You
 

gamerk316

Distinguished
Jul 8, 2008
325
0
19,060
26
Well, it IS an old card, but it shouldn't be that bad...could be a lot of things, from Creatives crappy drivers, to bad speakers. We need a bit more information to work with...
 

Navy_CD

Distinguished
Feb 15, 2010
3
0
18,510
0
Well, I just bought the card New, and I use Head phones not speakers. When I reboot my computer, it comes up with seeing the card but then tells me that that I'm missing a "Multimedia Audio Controller" and then it tells me that my hardware is not configured correctly and my not work. My computer is a P4 2.26gig....yea, it's about five years old, but everything else is working correctly.......Any ideas???
 

Navy_CD

Distinguished
Feb 15, 2010
3
0
18,510
0
No worries. I finally contacted Creative and they sent me the correct drivers this time. Now it's just fine tuning the damn thing.....Thank you
 
Thread starter Similar threads Forum Replies Date
S Audio 8
D Audio 4
T Audio 1
N Audio 3
A Audio 2
D Audio 2
C Audio 1
M Audio 9
M Audio 3
R Audio 1
Mike Andronico Audio 1
F Audio 1
R Audio 5
J Audio 1
M Audio 4
S Audio 1
crisso2face Audio 2
rickzor Audio 8
G Audio 1
T Audio 1

ASK THE COMMUNITY