Question SD Card reader not working "The configuration registry database is corrupt"

MrRyan2582

Commendable
Feb 20, 2017
2
0
1,510
0
So for a while now, I've come to notice my SD card reader on my ASUS laptop is not working. I don't think I ever tested it out to see if it ever worked since I got it a couple months ago. I've tried cleaning out the port, tried different cards, but it was no use. I went to Device Manager to see if it was being recognized, and it turns out, whenever I put in my SD card, it did show up. It was malfunctioning under the "Other Devices" tab. When checking the reader, it said Code 28 (The drivers for this device are not installed. There are no compatible drivers for this device). I went through the built in Windows troubleshooting, and it said it found the proper drivers for it, and was going to update it. However, it gave me an error, saying "The configuration registry database is corrupt". I have no idea where to go from here.

It says it is called "Genesys Logic USB3.0 Card Reader". My laptop is a ASUS ROG Strix GL703GM. Please help!
 
Thread starter Similar threads Forum Replies Date
P Laptop Tech Support 1
T Laptop Tech Support 3
M Laptop Tech Support 1
D Laptop Tech Support 6
V Laptop Tech Support 1
V Laptop Tech Support 1
M Laptop Tech Support 3
P Laptop Tech Support 2
W Laptop Tech Support 1
C Laptop Tech Support 1
G Laptop Tech Support 5
L Laptop Tech Support 4
C Laptop Tech Support 1
T Laptop Tech Support 5
D Laptop Tech Support 1
J Laptop Tech Support 1
D Laptop Tech Support 1
C Laptop Tech Support 1
B Laptop Tech Support 2
T Laptop Tech Support 6

ASK THE COMMUNITY