setting mail options with provisioning xml file

G

Guest

Guest
Archived from groups: microsoft.public.pocketpc (More info?)

Hello!

I would really appreciate any help to solve the following problem:

I have created an email account using a XML provisioning file. The only
issue I cannot solve, is to set the listbox in the e-mail options dialog
(Options 3/3) to "Get full copy of messages".

1. I created my mail account using a XML provisioning file.
2. On the PPC I open Inbox, select Accounts and choose my created account.
3. The "E-mail setup" dialog is displayed (page 1 of 4).
4. I click on "Next" until "E-mail setup" page 4.
5. There I click on "Options".
6. On the third page of the "Option" dialog I select "Get message header
only" in the top listbox.

7. Now I run "rapiconfig /P /M query.xml" where "query.xml" looks like:

<wap-provisioningdoc>
<characteristic type="EMAIL2">
<characteristic-query type="{751F77F6-920D-43e3-AFCB-7888B2666C63}"/>
</characteristic>
</wap-provisioningdoc>



8. The returned "RapiConfigOut.xml" looks like:



<wap-provisioningdoc>
<characteristic type="EMAIL2">
<characteristic type="{751F77F6-920D-43e3-AFCB-7888B2666C63}">
<parm name="SERVICENAME" value="MMS"/>
<parm name="SERVICETYPE" value="MMS"/>
<parm name="INSERVER" value="mms"/>
<parm name="AUTHNAME" value="user@mms"/>
<parm name="DOMAIN" value=""/>
<parm name="OUTSERVER" value="mms"/>
<parm name="REPLYADDR" value="user@mms"/>
<parm name="NAME" value=""/>
<parm name="LINGER" value="15"/>
<parm name="RETRIEVE" value="0"/>
<parm name="KEEPMAX" value="25"/>
<parm name="DWNDAY" value="4294967295"/>
<parm name="AUTHREQUIRED" value="0"/>
</characteristic>
</characteristic>
</wap-provisioningdoc>



9. Now I go back to the device and repeat steps 2 to 5, but on the 3rd page
of the "Options" dialog I select "Get full copy of messages".

10. I execute "rapiconfig /P /M query.xml" again and now get back:



<wap-provisioningdoc>
<characteristic type="EMAIL2">
<characteristic type="{751F77F6-920D-43e3-AFCB-7888B2666C63}">
<parm name="SERVICENAME" value="MMS"/>
<parm name="SERVICETYPE" value="MMS"/>
<parm name="INSERVER" value="mms"/>
<parm name="AUTHNAME" value="user@mms"/>
<parm name="DOMAIN" value=""/>
<parm name="OUTSERVER" value="mms"/>
<parm name="REPLYADDR" value="user@mms"/>
<parm name="NAME" value=""/>
<parm name="LINGER" value="15"/>
<parm name="RETRIEVE" value="4294967295"/>
<parm name="KEEPMAX" value="25"/>
<parm name="DWNDAY" value="4294967295"/>
<parm name="AUTHREQUIRED" value="0"/>
</characteristic>
</characteristic>
</wap-provisioningdoc>


11. The only parameter that changed is the "RETRIEVE" parameter. The value
4294967295 should now set "Get full copy of messages".

12. I manually change back to "Get message headers only" on the device and
send back above XML code from the "RapiConfigOut.xml", assuming to see a
change to "Get full copy of
messages". Rapiconfig reports "config succeeded", but I cannot see any
changes!



What do I wrong? How can I apply this setting?

Thanks for your help!



Peter
 

randalsp

Distinguished
Oct 24, 2011
1
0
18,510
0
Hi, did you ever work this out ? I have exactly the same issue now.....Thanks!

Archived from groups: microsoft.public.pocketpc (More info?)

Hello!

I would really appreciate any help to solve the following problem:

I have created an email account using a XML provisioning file. The only
issue I cannot solve, is to set the listbox in the e-mail options dialog
(Options 3/3) to "Get full copy of messages".

1. I created my mail account using a XML provisioning file.
2. On the PPC I open Inbox, select Accounts and choose my created account.
3. The "E-mail setup" dialog is displayed (page 1 of 4).
4. I click on "Next" until "E-mail setup" page 4.
5. There I click on "Options".
6. On the third page of the "Option" dialog I select "Get message header
only" in the top listbox.

7. Now I run "rapiconfig /P /M query.xml" where "query.xml" looks like:

<wap-provisioningdoc>
<characteristic type="EMAIL2">
<characteristic-query type="{751F77F6-920D-43e3-AFCB-7888B2666C63}"/>
</characteristic>
</wap-provisioningdoc>



8. The returned "RapiConfigOut.xml" looks like:



<wap-provisioningdoc>
<characteristic type="EMAIL2">
<characteristic type="{751F77F6-920D-43e3-AFCB-7888B2666C63}">
<parm name="SERVICENAME" value="MMS"/>
<parm name="SERVICETYPE" value="MMS"/>
<parm name="INSERVER" value="mms"/>
<parm name="AUTHNAME" value="user@mms"/>
<parm name="DOMAIN" value=""/>
<parm name="OUTSERVER" value="mms"/>
<parm name="REPLYADDR" value="user@mms"/>
<parm name="NAME" value=""/>
<parm name="LINGER" value="15"/>
<parm name="RETRIEVE" value="0"/>
<parm name="KEEPMAX" value="25"/>
<parm name="DWNDAY" value="4294967295"/>
<parm name="AUTHREQUIRED" value="0"/>
</characteristic>
</characteristic>
</wap-provisioningdoc>



9. Now I go back to the device and repeat steps 2 to 5, but on the 3rd page
of the "Options" dialog I select "Get full copy of messages".

10. I execute "rapiconfig /P /M query.xml" again and now get back:



<wap-provisioningdoc>
<characteristic type="EMAIL2">
<characteristic type="{751F77F6-920D-43e3-AFCB-7888B2666C63}">
<parm name="SERVICENAME" value="MMS"/>
<parm name="SERVICETYPE" value="MMS"/>
<parm name="INSERVER" value="mms"/>
<parm name="AUTHNAME" value="user@mms"/>
<parm name="DOMAIN" value=""/>
<parm name="OUTSERVER" value="mms"/>
<parm name="REPLYADDR" value="user@mms"/>
<parm name="NAME" value=""/>
<parm name="LINGER" value="15"/>
<parm name="RETRIEVE" value="4294967295"/>
<parm name="KEEPMAX" value="25"/>
<parm name="DWNDAY" value="4294967295"/>
<parm name="AUTHREQUIRED" value="0"/>
</characteristic>
</characteristic>
</wap-provisioningdoc>


11. The only parameter that changed is the "RETRIEVE" parameter. The value
4294967295 should now set "Get full copy of messages".

12. I manually change back to "Get message headers only" on the device and
send back above XML code from the "RapiConfigOut.xml", assuming to see a
change to "Get full copy of
messages". Rapiconfig reports "config succeeded", but I cannot see any
changes!



What do I wrong? How can I apply this setting?

Thanks for your help!



Peter
 

ASK THE COMMUNITY