Setup issues for pc to projecor

ithloss8

Honorable
Sep 13, 2013
25
0
10,580
0
ATM i have setup my PC to connect into a Receiver and the Receiver to my projector via HDMI cables. The issue that I'm having is a strange one that I'm sure has a fix to it but ATM its baffling me.. In saying this here are the 2 issues that I'm having

1) with everything plugged in correctly, receiver HDMI is plugged into HDMI 1 socket in projector, i then set projector to HDMI 1 input..PC picture comes up on the screen but i can only get my desktop speakers to work nothing comes out the 5.1 surround.. My receiver doesn't show up in the Audio playback options, nor is it showed in the disconnected/disabled section..

Now this is where it gets weird

2) now with the same setup leaving the projector on HDMI input 1 i physically move the HDMI cable from socket 1 to socket 2 and plug it in...Now i loose the picture on the screen but suddenly the receiver shows up in the Audio playback section and I'm able to set it as default and i can get sound playing through my 5.1 surround setup...but just no picture..

As i said i am baffled and have no idea what to do.. I have updated all my chip-set/audio/graphics and network drivers to the latest versions and nothing makes a difference.. I know its gonna be something simple but i cant work it out. Any help would be greatly appreciated cheers

these are my PC/Projector and Receiver specs thanks
PC - I5 4690, B85-G43 gaming motherboard, Sapphire AMD radeon r7 265 duel x graphics, 16g Ram, windows 10 64-bit

Receiver - Pioneer vsx-922

Projector - Sony VPL-HW40EWS
 

boju

Distinguished
Confusing yes but least we know now from pc to avr hdmi out is all fine that side of things. Projector is doing something to the avr noidea what, to cause an absense of sound could only be the hdmi cable in the ceiling and connection ends maybe.

There any chance you can test the projector with another hdmi cable when you get time, maybe bring it down to test with another hdmi cable if you dont have the length?
 

Rhinofart

Distinguished
Jan 30, 2006
44
0
18,610
8


When you right click on your taskbar icon for Sound, and select Playback Devices. Select HDMI audio. Depending on your VC setup, there may be multiple options to select.
I have one of my computers output from HDMI to my Harmon Kardon 2600, out to my VPL-HW40EWS and everything works perfectly. I did have to change my audio output in the control panel I stated earlier, but it all works. I have video going to my projector, and 7.1 surround coming out of the HK. That Sony projector is AWESOME! I love it for gaming. There is literally no input lag what so ever.

One thing I think you should try is to switch the HDMI cables around. Just to isolate that it's not a cable issue somewhere.
 

boju

Distinguished
Hi there

I've had experience with using an avr with a pc to a tv, hoping for you its just a simple hdmi channel that needs to be selected.

Im basing it on a yamaha rx1800 avr which is similar to yours.

From gpu hdmi to avr on hdmi channel 1

Avr hdmi out to tv

I select hdmi channel on the avr via remote to hdmi 1 that the pc is using.

Avr hdmi out can passthrough all hdmi channels individually depending on selected hdmi input

Windows audio playback devices needs to be changed to amd digital audio and it should have a tv icon coloured and not greyed out indicating a detected connection abling to set as default.
 

ithloss8

Honorable
Sep 13, 2013
25
0
10,580
0
When you right click on your taskbar icon for Sound, and select Playback Devices. Select HDMI audio. Depending on your VC setup, there may be multiple options to select.
I have one of my computers output from HDMI to my Harmon Kardon 2600, out to my VPL-HW40EWS and everything works perfectly. I did have to change my audio output in the control panel I stated earlier, but it all works. I have video going to my projector, and 7.1 surround coming out of the HK. That Sony projector is AWESOME! I love it for gaming. There is literally no input lag what so ever.

One thing I think you should try is to switch the HDMI cables around. Just to isolate that it's not a cable issue somewhere.
[/quotemsg]

the only thing that comes up right clicking it thats selectable is disable, show disable/disconnected devices
, about software midi synthisizer and properties...and in properties it says its working properly but it aint lol
 

boju

Distinguished


On which icon are you right clicking to get that message?

The highlighted device playback icon you're looking will be similar to this picture;


If you can take a snap shot of your playback devices page would be great
 

ithloss8

Honorable
Sep 13, 2013
25
0
10,580
0
so this is a pic of it with sound but no picture in the opposite hdmi port on the projector
[/URL][/img]

[/URL][/img]
this is a pic of it with a picture but no sound in the correct hdmi port

[/URL][/img]

this is right clicking when its got picture but no sound
 

ithloss8

Honorable
Sep 13, 2013
25
0
10,580
0
this is a pic with picture but no sound connected to correct hdmi in projector
[/URL][/img]

this is a pic with sound but no picture with the hdmi is socket 2 of projector while hdmi 1 is selected
[/URL][/img]



this is a pic with picture no sound with right click
[/URL][/img]
 

ithloss8

Honorable
Sep 13, 2013
25
0
10,580
0
just tried that and nothing workd...i have no idea.....this setup used to work but ive moved all the gear around to a different part of the house and now resetting it up its not working lol..i havent got the foggiest of the issue :(
 

boju

Distinguished
Sorry phone stuffup with best answer

Thought that came to mind is colour format in gpu properties, wondering if any settings there could make a difference using different format, maybe.

https://pcmonitors.info/articles/correcting-hdmi-colour-on-nvidia-and-amd-gpus/
Ill try think of things if i do think of anything else will let ya know. If you find out what it is would like to know :)
 

boju

Distinguished
You can get a picture on the projector so i don't think it has anything to do with colour format, ignore that.

This picture where you get a display but no sound




What happens if you disable the speakers, does anything show up as ready? Or are all related high definition listings with TVs all show as not plugged in?

 
Thread starter Similar threads Forum Replies Date
mhyss3 Streaming Video & TVs 3
S Streaming Video & TVs 0
J Streaming Video & TVs 3
F Streaming Video & TVs 0
ddk0014 Streaming Video & TVs 1
A Streaming Video & TVs 1
A Streaming Video & TVs 2
D Streaming Video & TVs 1
J Streaming Video & TVs 1
B Streaming Video & TVs 2
F Streaming Video & TVs 2
S Streaming Video & TVs 7
T Streaming Video & TVs 2
K Streaming Video & TVs 1
W Streaming Video & TVs 4
A Streaming Video & TVs 1
K Streaming Video & TVs 1
T Streaming Video & TVs 1
C Streaming Video & TVs 1
T Streaming Video & TVs 1

ASK THE COMMUNITY