Sleep issues (Windows 10)

chewyfood

Prominent
Aug 27, 2017
7
0
510
0
With my windows 10 install on my m.2 SSD (THNSN5128GPU7) the amount of time to put the computer into sleep mode is pretty bad - ~80 sec+. Moreover, attempting to return from sleep always results in a PC crash with the BSOD and the error CRITICAL_PROCESS_DIED, no other code information. It goes to a full white screen and then the BSOD comes up not long after that.

The strange thing is that on my Windows 10 install on my 2.5" mechanical SATA drive (same laptop, two hard drive bays, 1x m.2 and 1x SATA), putting the computer into sleep takes a few seconds and coming back from sleep is instantaneous. Given that information, I don't think it is something hardware related.

I have tried going back a step in BIOS firmware to no avail (the same older BIOS works fine with the 2.5" mechanical SATA drive).

Things I have tried:
-disabling hibernation
-turning off fast boot
-going back a step in BIOS firmware
-updating to the latest 11.2 intel management engine firmware (the 2.5" SATA windows 10 install is using version 11.0)
-rolling back to the old 9.5 intel management engine firmware (read a few forums which said this might work)
-removing the SATA drive to have only the m.2 in the machine

All drivers are OK. Nothing yellow.
 

chewyfood

Prominent
Aug 27, 2017
7
0
510
0


Unfortunately, no DMP files are being created. I see a message in the event viewer labeled "Error" from volmgr with the details: "Dump file creation failed due to error during dump creation". I always watch the BSOD and see the status %. It never moves from 0% (I usually expect it to go to 100% to indicate a full memory dump).


The details tab of the eventlog entry show \device\harddiskvolume8. Diskpart only shows 6 volumes.
0 = C primary 118GB
1 = C recovery 450MB
2 = C FAT32 100MB
3 = D primary 465GB
4 = D FAT32 100MB (Windows 10 install on secondary HD)
5 = D recovery 511MB (Windows 10 install)

Volumes 6 through 8 I think are the ones I disabled on the C drive - they show up as 0GB disk drives that I can't do anything with. They were giving me trouble starting the machine (delaying the boot up time from 16 seconds to 2 minutes).
 

googlyeyedchicken

Prominent
Sep 15, 2017
59
0
660
27
I found this forum string that may answer your issue. Scroll down to the bottom to see what the guy did. Here is what he said...

It has been solved.

The issue was with the 6Gbit/s SATA port.
I have 8 ports. 1-6 are 3Gbit/s and 7-8 are 6Gbit/s.
My SSD (with Windows installed) was in port 7 (Its a 6GBit/s SSD). I tried port 8 and same issue.
Something funny I noticed, the BIOS only sees ports 1-6.
I tried it with the SSD in port 1 and it sees it in the BIOS and it now can go into and out of sleep mode without any issues.
It seems when you come out of sleep mode, because the BIOS cannot see port 7/8 Windows thinks the SSD is unplugged.

It is really annoying since I made sure I got SATA 3 motherboard and SSD for the speed.

I guess I need to contact MSI.

Thank you for your help.
Now to try and fix the issue with the USB 3.

In case any one else has this issue, I have posted this on the MSI Forum https://forum-en.msi.com/index.php?topic=175594.0

EDIT: I just noticed that my 2nd HDD (it's on port 8) gets disconnected after sleep mode. This is why it BSODed because the SSD was on port 7 and I guess the same thing happened to it as well.
 

chewyfood

Prominent
Aug 27, 2017
7
0
510
0


The laptop only has two hard drive ports, one SATA (with a mechanical WDC drive) and one m.2 slot (with the SSD). Both are occupied.
 
Thread starter Similar threads Forum Replies Date
D Laptop Tech Support 4
Psychedelico Laptop Tech Support 4
K Laptop Tech Support 0
M Laptop Tech Support 1
H Laptop Tech Support 1
M Laptop Tech Support 2
K Laptop Tech Support 7
S Laptop Tech Support 8
I Laptop Tech Support 2
C Laptop Tech Support 3
Z Laptop Tech Support 1
J Laptop Tech Support 1
K Laptop Tech Support 2
zamandguth Laptop Tech Support 5
M Laptop Tech Support 1
R Laptop Tech Support 3
X Laptop Tech Support 4
A Laptop Tech Support 2
N Laptop Tech Support 4
J Laptop Tech Support 4

ASK THE COMMUNITY