Sound not working in right side

Arigo

Distinguished
Mar 25, 2009
6
0
18,510
0
I have a set of Tritton AX 51 pro, about 2 months ago, i dropped them and the sound in the left side stopped working, so I RMAed it. They sent it back about a month later, and it was working, I recently dropped it again, and the light on the right side wasnt working, but sound was still fine. Now it starts cutting in and out, and I'm almost positive it is a lose wire. Im not RMAing it again, any suggestions for a self fix? If i were to take it apart, what would I be looking for to fix? (I know it voids warranty, but its already over and I dont really care.)
 

lazyperson17

Distinguished
Jul 14, 2010
60
0
18,590
11
If your looking at a set of stand alone speakers, check the 3.5mm jack which should plug into the headphone jack of your computer. Make sure this is clean, and that there isnt anything in the headphone jack itself. Second, check the line that connects your speakers to the computer for any snares, cuts, slices, nibbles anything. Lastly, plug in a separate set of speakers to make sure it is the speakers that are causing the issue. If they are, and there are no issues in the connecting line, open it up and look for two wires which should be connected to the back of the cone. There should be two wires, and if done properly, there should be one red, and one white. (usually). Make sure these are connected properly.

If your looking at a laptop... You will be looking for 2 wires which will be a positive and negative. (Red will most likely be positive, white will most likely be negative.) These two wires will be connected to the back of the speaker and then to the computer (sound card, or motherboard).
 

Arigo

Distinguished
Mar 25, 2009
6
0
18,510
0


Thanks a lot, I found a temporary fix, by taping the wire coming out of the control module thing, just to it. (When I moved the cable around the sound would cut in and out.) So if it stops working, I'll have to open it up, and take a look.
 

Arigo

Distinguished
Mar 25, 2009
6
0
18,510
0
Temp fix stopped working, I opened it up, and found MANY different little tiny wires that were soddered onto a chip, I couldnt find any that looked lose.. Im sure that if there is one I missed, all I would have to do would be to sodder it back on..
 
Thread starter Similar threads Forum Replies Date
G Audio 0
Luckykor Audio 0
kk897 Audio 1
P Audio 4
C Audio 2
J Audio 0
Ice Bear Audio 5
A Audio 1
F Audio 0
TheSLIP Audio 1
HoomanSacrifice Audio 12
B Audio 5
R Audio 1
S Audio 1
kobinath Audio 1
Kynai Audio 2
A Audio 2
S Audio 1
M Audio 1
W Audio 1
Similar threads
Question No sound during calls on my earbuds, everything else works fine. I've tried everything. Please help!
Question Sony TV A8 55 oled and Onkyo TR646 connected via arc. Only sound coming from external devices works.
Question The microphone is working and my Mac detects the device, but won't transfer sound - why?
Question Active speaker output for passive pair is not working
Solved! 5.1 Surround Sound no audio playing on PC
Question Headphone sound Working, However mic not working!
Solved! AT2020 not working with Neewer 48v phantom power box and usb sound card
Hello need some help cant get my headset to work
Question Very low and muffled sound on the Beyerdynamic MMX300 2nd Gen
Question Sony HT-100SF Soundbar not working with Samsung Television
Question Vizio Surround Sound speakers not working SB3581
Question Subwoofer on 2.1 speaker system not working(Logitech Z623) when connected via aux
Question av receiver sound not working
Question Headphone sound and mic port suddenly not working
Question MK-F100TL Wired Microphone USB Condenser Sound Recording is not working in my laptop
Question NO SURROUND SOUND WORKING ON MY PC
Question Hello, I have AOC u2868pqu and also no sound coming out of the built-in speakers. I found out the speakers only work only when PIP/PBP is turned on
Mic doesn't work when both slots of sound card is used
Solved! I'm trying to connect a polk sd1 sound bar to a Toshiba 58L5400U TV. I connected the optical wire, but it will not work. It's
Solved! No sound from DVD-worked for years [SOLVED]

ASK THE COMMUNITY