Switchable Graphics BS

Florin_8

Commendable
Jan 29, 2017
1
0
1,510
0
So, I have a Laptop Dell- Inspiron 15 -i7 - 8 GB Ram- Ati Radeon R 5 - 4 GB Switchable graphics ( with intel bla bla ) ...ALL Games are working like crap. laggs a lot.like 2 FPS seems sometimes even from games like NFS most wanted or older games .I have installed all possible drivers, set all preferences on high performance against battery save, I understand from the only post seemed to be a complete explenation that the only way to make it work is to completely disable from Bios the onboard one and make the ATi default / main Video adapter as it is only used as a ''Helper'' of the onboard one no matter what , which in my bios is nowhere to be found , there are no advanced option even after update-ing the Bios. If I disable the Intel graphic from device manager the games will not recognize the ATi neither. ...I would reaaaaly appreciate a good resolution to this. Thank you !
 
The Radeon is AMD actually. :)


First you need to get it to detect and use the right card.

A. Uninstall, and then reinstall, the latest graphics card driver.
B. Make sure that your AMD graphics card is set as the default graphics card.

Here's the steps on how to set it to default.

1. Open the "Control Center".
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance AMD processor.

Once it is running on the right one, test the system again and see if the problem persists.


For ATI/AMD graphics cards the process varies.

You may need to open graphics then PowerPlay and set plugged in and/or battery to maximize performance.

You can also try going to graphics then 3D and move the slider to performance. Your computer may also have a switchable graphics tab where you can change the settings for individual programs.
 
The Radeon is AMD actually. :)


First you need to get it to detect and use the right card.

A. Uninstall, and then reinstall, the latest graphics card driver.
B. Make sure that your AMD graphics card is set as the default graphics card.

Here's the steps on how to set it to default.

1. Open the "Control Center".
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance AMD processor.

Once it is running on the right one, test the system again and see if the problem persists.


For ATI/AMD graphics cards the process varies.

You may need to open graphics then PowerPlay and set plugged in and/or battery to maximize performance.

You can also try going to graphics then 3D and move the slider to performance. Your computer may also have a switchable graphics tab where you can change the settings for individual programs.
 
Thread starter Similar threads Forum Replies Date
Kinomi Laptop Tech Support 2
arcanaxion Laptop Tech Support 1
D Laptop Tech Support 2
Z Laptop Tech Support 1
S Laptop Tech Support 1
S Laptop Tech Support 3
B Laptop Tech Support 2
A Laptop Tech Support 1
B Laptop Tech Support 6
R Laptop Tech Support 3
K Laptop Tech Support 1
A Laptop Tech Support 1
3 Laptop Tech Support 1
alexdunker Laptop Tech Support 5
M Laptop Tech Support 1
S Laptop Tech Support 1
maxeon Laptop Tech Support 2
S Laptop Tech Support 6
S Laptop Tech Support 2
X Laptop Tech Support 1

ASK THE COMMUNITY