Tablet won't boot after discharging completely

WhatsMyProblem

Estimable
Jun 11, 2014
4
0
4,510
0
Hi, I tried everything but could not figure out what to do, so i'm here asking you guys. So I was using my tablet normally. I bought it 3-4 month ago, at the Black Friday. It's an Asus Memo Pad me170c (K01A). 2 days ago, i was using my tablet that I had charged and started using it. When it started discharging (around 20-15%) i plugged it, but i didnt realize it was'nt charging. I realized when it was at 3% but i could not do nothing for it. I tought when it'd discharge, it would simply charge like normally so i let it go. Once it discharged, surprisingly it did not start charging. I tried to boot the tablet, but it would always shut down after i get past the ASUS logo. I then held the volume button while powering it, and it showed me an empty battery logo with an question mark inside, and it would shut down afterwards. Now, it's only showing me a red battery logo, sign of discharge and it seems to boot itself but it shut downs after 5 seconds ( Logo pops, screen brightens then it shuts down. I tried different chargers, so it could not be mine. I tried a youtube video where you need to open the tablet, unplug the battery wires then re-plug them but it didnt work so I guess it's not the battery too. I think it is the charger port that is damaged, but i'm not sure. I searched tons of forums, but nothing, please help.

Thanks in advance !
 
Thread starter Similar threads Forum Replies Date
woodhead666 Android Tablets 0
M Android Tablets 1
M Android Tablets 1
E Android Tablets 1
S Android Tablets 0
A Android Tablets 0
J Android Tablets 0
ttro89 Android Tablets 3
C Android Tablets 2
tyra012 Android Tablets 3
JexplorHELP Android Tablets 4
Truefate Android Tablets 1
Helpmeplease838462 Android Tablets 5
J Android Tablets 1
J Android Tablets 6
J Android Tablets 4
pointlesszebra Android Tablets 0
F Android Tablets 1
P Android Tablets 9
K Android Tablets 1

ASK THE COMMUNITY

TRENDING THREADS