Thought my old sound card was broken so I bought a new one, microphone still doesn't work!

Feb 13, 2018
8
0
10
0
As it's stated in the title I bought a new sound card because nothing else I had tried or was suggest would work. It's set as default recording device, they are plugged in all the way and correctly, and it doesn't show any green bars when I speak, I honestly have no idea what to do.
I'm on windows 10 with a xonar dgx sound card and a logitech g233 headset. I'm almost positive it isn't the headset because my apple headphones won't work either.
 

Robert Ban

Estimable
Jul 30, 2014
437
0
6,010
109
Apple headphones have combined microphone and headphones, headphones for PC have dedicated, unless you have connector for combined, are you sure that your microphone on headset isn't broken, have you checked that you didn't switch to mute on volume knob?
 
Feb 13, 2018
8
0
10
0


I have a headphone splitter for the apple headphones and my headset is not muted, also I bought that headset brand new because I thought my other one was broken since it didn't work on my computer but I guess that wasn't the problem

 
Feb 13, 2018
8
0
10
0


I have a headphone splitter for my apple earbuds, my headset is not muted, and the other headset I have also doesn't work on it and I bought it brand new so it's definitely not the headset that is at fault
 

Robert Ban

Estimable
Jul 30, 2014
437
0
6,010
109
Have you checked in microhpone options in Levels tab that is actually 100 not 0?
Which sound card and motherboard do you have?
Did you right click on Recording tab and showed disabled devices?
 
Feb 13, 2018
8
0
10
0


Motherboard is an MSI z270, new sound card is a xonar dgx, the levels tab is turned up, I have shown disabled devices and neither mics are one of them

 
Feb 13, 2018
8
0
10
0


Yeah I've already seen a video like that one and changed it from front panel.

This is a couple snips I took of the DGX control panel, https://imgur.com/a/avkxC

 
Feb 13, 2018
8
0
10
0


yes
 

anort3

Distinguished
Moderator
OK so when you select it you can open the Properties and Configure sub menus.

Under properties make sure use this device is selected. Make sure the levels are turned up. And under advanced make sure allow applications to take control of this device is enabled.

Under configure try set up your microphone.
 

anort3

Distinguished
Moderator
You know the Apple splitter may not work with anything but Apple devices. Your headset has one cable that you're splitting into 2 right? One for the headphone port and one for the mic port?
 
Feb 13, 2018
8
0
10
0


I also have another headset separate from the logitech one which also didn't work and it has 2 plugs and yes, it has one cable I'm splitting into two, also I'm sure they're in the right slots. I've also already tried to configure it in properties and nothing has happened
 

anort3

Distinguished
Moderator
I'm at a loss then. I have a Xonar Essence STX with a very similar control panel and I don't see anywhere to configure a mic in there. I've had the card close to 7 years but I've never used a mic with it.

 

ASK THE COMMUNITY