Toshiba C40D-A Faulty BIOS?

apbjammin

Commendable
May 9, 2016
2
0
1,510
0
Hey all,

I've been attempting to fix a Toshiba C40D-A laptop that was having extremely long boot times. The current issue is that it takes several hours to boot even to the BIOS screen, and during that time it boots directly to a black screen.

Components I've tested:

    RAM - Reseated each of the sticks of RAM individually, no change
    Hard Drive - Connected to my Desktop and it boots instantly, scanned it multiple times and wiped it clean
    Windows - Clean installed, no change
    Screen - Works perfectly once the computer has actually managed to boot to BIOS
    Removing and reinserting CMOS battery and power cycling


I believe at this point it's an issue with the BIOS, and from what I've read it could be that there are numerous errors it's churning through before it can even get to that stage. The problem I'm now running into is an error message when I try to update the BIOS stating "Invalid Firmware Image". This happens using any of the published versions of the Toshiba BIOS for this laptop. Current version is 1.2, and none of versions 1.0, 1.1, 1.2, 1.5, or 1.6 have worked yet.

If you have any suggestions for how to possibly update the BIOS, or possible solutions to try, I'd greatly appreciate the help.

Thanks
 
Thread starter Similar threads Forum Replies Date
W Laptop Tech Support 0
E Laptop Tech Support 1
Bluemoon1502 Laptop Tech Support 1
G Laptop Tech Support 3
O Laptop Tech Support 5
D Laptop Tech Support 1
M Laptop Tech Support 3
D Laptop Tech Support 0
T Laptop Tech Support 1
XVII Laptop Tech Support 0
R Laptop Tech Support 1
B Laptop Tech Support 8
KnottyCord Laptop Tech Support 2
ahindi Laptop Tech Support 0
Debs70 Laptop Tech Support 3
R Laptop Tech Support 0
Blitzkreig Laptop Tech Support 1
S Laptop Tech Support 1
G Laptop Tech Support 1
U Laptop Tech Support 6

ASK THE COMMUNITY