Toshiba Laptop CPU running at max, overheating

JT McCutcheon

Estimable
Oct 4, 2014
2
0
4,510
0
I previously posted this issue at the Microsoft Community, but nobody there was any help, and neither was the local tech center. I have had a Toshiba Satellite for 2 or 3 years now, and it has had this problem for over a year. To be honest, I have no idea what the hell is wrong with it. It has a dual core i5, and these pictures show that one thread in one core is running almost at maximum.

http://
http://

I completely re-installed Windows, the issue is present in Ubuntu, and i hear the fan kick on even in the BIOS. The inside of the machine is clean. Antivirus can't find anything. Toshiba Health utility reports that the processor has a temp of 58-64% (no idea how hot that is for the i5) and the fan cycles from 67 to 83% at an idle. I don't know if this is good for the fan or not, but it is very loud and annoying. Here is all the processes taking CPU time.

http://

Thanks to anybody that can help!

Edit: Pictures did not show up, links now to Google Drive
 
If the problem is happening in both Windows and Ubuntu, it's probably a hardware defect. My guess would be that the one core's Speedstep functionality is broken and it's unable to enter into the lower frequency/power states. You can check if your BIOS has settings to enable/disable Speedstep or change the low power/sleep states, and try toggling them (equivalent to hitting a noisy fan to try to "shake" it into place). But I'm doubtful it would work.

Windows lets you manually set processor speeds. Start -> Control Panel -> Power Options -> Change Plan Settings (for your current plan) -> Advanced. Then in the dialog which pops up, scroll down to Processor power management. Try changing the Maximum processor state to something like 5%. See if that slows down the core enough to quiet down the fan. If my above theory is right, it won't do anything (for that core at least) and may even crash Windows.

If it does quiet down the fan, I guess that's one way to live with it. Try increasing the max frequency until the fan is tolerable. You could even set up multiple power profiles for low, medium, and full (100%) fan noise, and manually switch between them via the power management setting (should be accessible with the battery icon in your toolbar) depending on if you want the laptop to run slow and quiet, or fast and noisy. Unfortunately, I don't think there's a way to set a power state for a single core (so you could just cap that core at 5% and let the other scale automatically). But I could be wrong - feel free to search.
 
If the problem is happening in both Windows and Ubuntu, it's probably a hardware defect. My guess would be that the one core's Speedstep functionality is broken and it's unable to enter into the lower frequency/power states. You can check if your BIOS has settings to enable/disable Speedstep or change the low power/sleep states, and try toggling them (equivalent to hitting a noisy fan to try to "shake" it into place). But I'm doubtful it would work.

Windows lets you manually set processor speeds. Start -> Control Panel -> Power Options -> Change Plan Settings (for your current plan) -> Advanced. Then in the dialog which pops up, scroll down to Processor power management. Try changing the Maximum processor state to something like 5%. See if that slows down the core enough to quiet down the fan. If my above theory is right, it won't do anything (for that core at least) and may even crash Windows.

If it does quiet down the fan, I guess that's one way to live with it. Try increasing the max frequency until the fan is tolerable. You could even set up multiple power profiles for low, medium, and full (100%) fan noise, and manually switch between them via the power management setting (should be accessible with the battery icon in your toolbar) depending on if you want the laptop to run slow and quiet, or fast and noisy. Unfortunately, I don't think there's a way to set a power state for a single core (so you could just cap that core at 5% and let the other scale automatically). But I could be wrong - feel free to search.
 

JT McCutcheon

Estimable
Oct 4, 2014
2
0
4,510
0


Well, I set the maximum for 5 percent, and it quieted down. I believe Speedstep is Intel's "Turboboost", yes? If so, I will give it a go, and if nothing comes of it, I'll just live with it till next year when I get a new computer. Also, will completely disabling Turbo Boost help?

Thanks a lot!
 

If 5% quiets it down, try cranking it up 5% at a time until the fan gets too loud, then set it back to the highest % with tolerable noise.

I believe Speedstep is Intel's "Turboboost", yes? If so, I will give it a go, and if nothing comes of it, I'll just live with it till next year when I get a new computer. Also, will completely disabling Turbo Boost help?
Functionally they're the same, but conceptually they're different with respect to the GHz rating of your CPU.

Speedstep is scaling down the CPU's clock speed slower than its rated speed. So if your CPU is 2.2 GHz, Speedstep may allow it to slow down to 800 MHz (that was the minimum on the Core 2 Duo I had, I haven't been able to find specs for the minimum on the i3/i5/i7). All Intel CPUs have Speedstep.

Turbo Boost is scaling up the CPU's clock speed faster than its rated speed. So your 2.2 GHz i5 could run at 2.7 GHz with max Turbo Boost. There's typically different max limits for Turbo Boost depending on how many cores are in use. e.g. an i7 may Turbo Boost by a max 500 MHz when using 4 cores, 700 MHz when using 2 cores, and 900 MHz when using 1 core. Only the i5 and i7 mobile CPUs have Turbo Boost.

Speedstep also reduces the voltage at lower speeds, thus resulting in even more power savings. I'm not sure if Turbo Boost changes the voltage. You used to be able to manually tweak these voltages with the Core 2 Duo, but Intel took away your ability to do so when they introduced the Core i3/i5/i7 series. They recently released a tool which gives you this capability back with newer CPUs. You can give it a shot to see if it gives you any more control over how your CPU is behaving.

http://www.intel.com/content/www/us/en/motherboards/desktop-motherboards/desktop-boards-software-extreme-tuning-utility.html

Be forewarned that you can cause your computer to crash using the above tool (set the voltage too low at a given clock speed, or the fan speed to low allowing the CPU to overheat). Try reading through some guides first so you know what you're doing (should be old hat if you've overclocked before).

https://www.google.com/?gws_rd=ssl#q=intel+xtu+guide
 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 19
K Laptop Tech Support 1
R Laptop Tech Support 2
P Laptop Tech Support 1
B Laptop Tech Support 5
L Laptop Tech Support 10
S Laptop Tech Support 1
neoxblu Laptop Tech Support 8
J Laptop Tech Support 3
I Laptop Tech Support 1
D Laptop Tech Support 1
D Laptop Tech Support 2
M Laptop Tech Support 1
H Laptop Tech Support 1
K Laptop Tech Support 6
A Laptop Tech Support 1
G Laptop Tech Support 1
S Laptop Tech Support 1
S Laptop Tech Support 3
R Laptop Tech Support 8

ASK THE COMMUNITY

TRENDING THREADS